+ Start a Discussion

Authorization denied with Flow on Sites

I am trying to publish a Flow embedded in a VF page as a Sites page, but I keep getting an authorization error. Even when I use a test flow of just a single screen and no database interaction I get an error, so I know it isn't the content of the Flow itself that is the problem. All the other non-Flow VF pages accessible from the site work just fine, so the site itself is working OK. The VF page (and it's controller) is listed in the "enable visualforce page access" for the public user profile of the site, so I know it isn't access to just the VF page, either. This is the most simple VF page possible - The only thing in the VF page is:


<apex:page Controller="FlowTesterController">
<flow:interview name="Tester"/>


and the class is simply:


public class FlowTesterController {
    public Flow.Interview.Tester myflow {get;set;}


Nevertheless, I keep getting the page "Authorization Required - You must first log in or register before accessing this page."

What else could affect the public permissions to show a Flow on Sites?



Check with support if you got the perms enabled to run th Flow on portals/sites. :smileywink:


I tried support, but they said that they won't address my issue because they don't do development support anymore, and directed me here.


A plain VF page works fine on the site, but as soon as I add a flow on the VF page it won't allow it. Here's my entire new VF page I try to use on a sites page:


<apex:page >
<flow:interview name="Tester"/>


Not even any controller now, but still when I try to use this I get the permissions error. When I remove the flow line (replacing with just text) it works fine. (The flow is just a tester with no database interaction, and it is active.)


Make sure you have an active version of the flow.

What is the first screen of the flow? If it is accessing any records, then you will have to set the CRUD/FLS on that object.


lastly, are you on sandbox or dev/production?


I was trying in a sandbox with the most basic VF page and flow possible (flow=just one screen with a display field). I tried it yesterday in production with the same basic setup and it worked. Argh. Now I have to deploy everything to production in order to test?!


I didn't activate my flow!  Thanks for the comment