function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Allocation not happening

So I'm pulling my hair out. I've put together a flow in the Desktop Flow Designer, and for some reason I have a Record Lookup allocation which is just not working for some reason.



Here is the section of my flow where the problem is occurring. I have a record lookup, getProfileName2, that is going to a decision, and then on certain conditions, moving to the Form chooseDirector.



Here's the filter for getProfileName2. The variable varClickerProfileID is being passed to the Flow by the custom URL that uses it. I know this is working because I have added a debug line to the Form, displaying the variable when it is run:


But notice the big blank section beneath that ID. I have a second debug line added there to display the variable varClickerProfileName, and it's not showing anything. This variable is supposed to be allocated by the record lookup, like so:



And it's not just the debug line that's not working. The decision decIsDirector that is between the Record Lookup and the Form is supposed to route based on the variable varClickerProfileName, and it is routing incorrectly. It's as if the Record Lookup's allocation is just not working. But it's not faulting either, so it's like it's doing something and pulling no data.


I have tried this with other variables and fields; I attempted to do the same with the boolean PermissionsModifyAllData, with no success. I simply cannot get this Record Lookup to work. I even tried recreating it.




Am still a bit unclear.

What is your decision condition for the decIsDirector?

Are you saying this condition does not evaluate correctly?


decIsDirector isn't really relevant to the problem; it just determines how to proceed based on $UserRole.Id. My debug testing to reach the debug screen is always running as a user that sends it down the NO path.


The problem is just with getProfileName. I know this because my debug screen (which is on ChooseDirector) shows a blank for the variable that is being defined in getProfileName. The data lookup simply isn't allocating any data into the varClickerProfileName variable as it's being told to do.


Thanks Rajaram!