function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

dynabean ajax 10.0

I have an old S-control using an old beta version of AJAX, which worked fine with IE6. However, it ran into some problems with IE7, which is why I try to change it. So, I'm having a problem with Dynabeans. The code below should show what I am trying to do:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "">
<script language="javascript" src="/soap/ajax/10.0/connection.js" type="text/javascript"></script>
var conn;
function initPage() {
    conn = sforce.connection;
    window.setTimeout(";", 1000);   
Now later in a function inwoked by getPictures:
     var rme = new conn.Dynabean("OwnEquipment__c");
This is where I'm having the problem. Tried to use .. rms = new sforce.Dynabean .. or Sforce.Dynabean .. or just Dynabean ..
Always an error like 'object expected'

Oops, this is the right syntax:

     var rme = new sforce.SObject("OwnEquipment__c");

Case dismissed!