+ Start a Discussion
sandip87sandip87 

Migrating tool Issues

Hi,

I have a namespace prefix in my current dev org with manage package installed. Now i want to remove that namespace from all components. In order to do so i must have to move/copy all my metadata to new dev org.

But i am facing problem while using migration tool. I tried using eclipse and ant but still have errors while deploying same.

Currently i have winter '14 release in my org so the API version is 29.0, the winter '14 release is automatically updated in my current dev org. and the org to which i want to deploy is still with API version 28.0. I created new dev org as i thought winter '14 release should be updated in new org but it wasn't happen.

Now i have two dev org with different version and want to deploy from v 29.0 to 28.0.

I am not able to deploy neither with ECLIPSE nor with ANT...there are so many errors.

Can anybody give me solution to overcome this problem if i missed some priority tasks or steps to follow. Here I'm listing steps that i have followd.

1. download ant and configere as mentioned in Migration tool guide.

2. download salesforce ant form dev org.

3.configure all things as in guide.

4. retrieve all metadata from org. (I retrieved all without any errors. version is 29.0)

5. Trying to deploy to salesforce org v 29.0 (using salesforce ant_28.0)

In step 5 i have no clues where to go and what to do as i configured all the files like build.xml,build.properties,package.xml and all that.

When deploy one by one, there is dependancy error as some objects doen't find refercend objects.

and I deploy in bulk there are so many errors.

I used same package.xml file which is saved during retrieveing.

Thanks

Satish_SFDCSatish_SFDC
Well, it all depends on the errors you receive. When you are uploading in bulk, you will get a list of errors which should give you a clue to what is happening.

Regards,
Satish Kumar