function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Saravanan @CreationSaravanan @Creation IDE Exception when downloading the project or refreshing

Hi All,

I am getting below exception when downloading the project.


below is the message:


Exception happened when resolving component type(s), so no component

will be added to the package manifest editor for these types.


See log for detail exception message.




Hi Sharavana,


Which version of Eclipse are you using?


If its Juno - 

Could you try configuring Eclipse to use your proxy server. These settings can be found in your Eclipse Preferences, under General > Network Connections.


(There have been few compatibility issues reported with Eclipse 4.2 (Juno))

Saravanan @CreationSaravanan @Creation

Hi ,


Thanks for your reply.


My eclipse version is 3.5.2


Could you please tell me how to configure the proxy server setting.

Saravanan @CreationSaravanan @Creation



I am very poor in nextwork knowleadge.


could you please tell me.How can i get my proxy sery and port details.




Hi Saravanan,


please check the following link which explains how to get the proxy settings on your machine:


Hi Sonam,


I am also getting the same error. However, as soon as I click on OK, it is letting me proceed as usual. 


However, as per solution given by you, I tried to find the proxy detail of my system/network and found that we don't have any proxy in place. We have 'Quick Heal' antivirus on all of our system though.


Your input on this is highly appreciated!



Digamber Prasad


I'm getting a similar error except it's *FlexiPage instead

I am getting the same error with *FlexiPage as well?
I am getting this same error with *FlexiPage. I have not been able to a resolution online. Help, anyone!
I have same prob *FlexiPage

User-added image
Jon ClineJon Cline
Any update here? We have having the same issue.
Pat PattersonPat Patterson
In Eclipse, do Help/Check for Updates, update the Eclipse plugin to version 30. I was seeing the problem in plugin v29, updated to v30, problem gone.
Jon ClineJon Cline
Thanks Pat. That seems simple enough though the only update available to me on the IDE is v28. Does that correlate you think?
Pat PattersonPat Patterson
What version of Eclipse are you using? You might need a more recent Eclipse version to get the latest plugin - see
I tried to upgrade and got an upgrade error: Unable to perform upgrade analysis. The exception has to do with LIMIT_EXCEEDED: Too many files in retrieve call, limit is 5000. Any idea how to get around this limit in order to complete the upgrade?
Pat PattersonPat Patterson
Unfortunately, there is a 400MB/5000 item limit on the Metadata API, and it looks like the upgrade process is trying to retrieve them all in one hit. You can re-create your project with the new plugin - create a new project, with just one metadata type (Apex Classes for example). Add more, type by type until you have all you need.
praveen murugesanpraveen murugesan
Hi All,

I got the same issue in my ide. While workaround this i got the solution. Its because of jre verions. If jre version is less than 1.7 means its working fine.

So its working fine jre1.6.0.25 with ide version 28.0

Praveen Murugesan.