+ Start a Discussion

Submitting forms using S-Control: how to get rid of the popups?



I am submitting a form using S-Control, and every time I click on "submit" button, an alert pops up twice saying:



This is a non-secure form.


This form will be sent in a way that is not secure. Are you sure you want to send it? 


[Cancel] [Send]



How do I get rid of these pop-ups?


I am on Mac using Safari.


Thanks in advance,

- Shashank 






I found out that this is a browser setting and can be turned off. In Safari it is under  Preferences > Security tab.

Uncheck the check box which says: Ask before sending a non-secure form from a secure website.