function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

CMSForce Help! - Row with duplicate Name at index: 3?? ERROR

I'm running into an error installing CMSForce for a client and saw that you're an active and knowledgable member of the boards so I thought to contact you directly. We were able to install and use CMSForce in the sandbox environment and then tried to install it in Production but ran into the issue of getting an Authentication Error when trying to view the Main Template within the CMSForce Console.


We uninstalled at this point since we were performing other migration tasks last night and this was holding us up.


This morning we went back in, tried to install CMSForce again, but then ran into the error that "CMSForce" Static Resource was already in the system. (This was brought in from our UI Designer last night as part of his migration of files). When we tried to delete the CMSForce Static Resource, we got the error that it was being referenced by a Component and Pages in the system. We went ahead an commented out any time the "Resource.CMSForce" was being called. At this point we were able to delete the CMSForce Static Resource.


We installed again and ignored the APEX test errors (it's a common error as you probably know). We followed the customization guide to a "T" and then tried to access the CMSForce App (top-right corner of SFDC). We got an error here as well, stating that there was a Duplicate Reference 3 error? At this point we don't know what to do and need to install this for the client today. ANY help would be more than appreciated!





Hm -- just reading through your message it sounds like you might have already had CMSForce or CMSForce2 installed in the target org.  Possible?  That could gum up the works.  Did you have data with the original app you installed in the production org or could it be safely uninstalled completely?  If it can be uninstalled, that's what I would do.  If not, I would: a) setup a sandbox so you can test in a non-production environment b) deploy to your sandbox using Eclipse IDE c) test thoroughly to be sure your IDE based deploy worked as expected.  HTH

David VPDavid VP

This definitely sounds like you have clashing installations of CMSForce.

A clean unistall (if possible) would have been the best way to go but since manual changes have been made, you'll probably have to clean it up manually as well.