function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Permission for WebLink object?

Hi all,


I run into a problem with the following line when I am not log in as Administrator. Does anyone know why and how to resolve this? Thanks in advance.


var tab = sforce.connection.query("Select from WebLink w where Name='Advisor'").records.Id;




It seems the profile with which you are logged in (other than Admin ) does not have the permissions required for the object, hence the issue. Try this create a new profile which has at least read permission on the given object , assign this new profile to your user and find if the problem still persists, if no then you know the cause of the issue faced by uou.


Did this answer your question? If not, let me know what didn't work, or if so, please mark it solved.


But I don't see WebLink as an object in profile setup page. What does it belong?


Anyone else has a solution or idea? Please suggest. I really need to solve this. Thanks.


You need the customize application permission to be able to access WebLinks via the API.


What do you mean by customize application permission? Where do I do that? I went to Create -> Apps -> My App, but I don't really see what I can change. Is it somewhere else?