function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Eclipse AppExchange plugin

Has anyone got this to work? I finally got it installed, but all it does is throw errors.

If I try to create a new AppExchange project, after I enter my project name and login info, I get a dialog that says "Invalid Thread Access" and I can't go any farther.

If I try to open the Schema Browser view, I get an error that says:

Unable to create view: Plug-in com.appexchange.toolkit was unable to load class com.appexchange.plugin.views.SchemaView.

This is using Eclipse 3.1.2 (the only version that I could get it successfully installed on).

I'd love to hear from anyone that is using this!


Todd Breiholz
Meredith Corporation
Hmm.. a few questions:

Did you install via the update site?

Did you try installing from a clean install of Eclipse?

What OS?
I did install via the update site.

It was a clean install of Eclipse 3.1.2 (I already had Eclipse 3.2M5a installed). I also created a new, clean workspace for this install.

This is on Windows XP Pro SP2.



Everything in the toolkit hinges on the ability to login, therefore, if you are unable to login other errors will be thrown. 

In your environment, are you behind a proxy server or have any other network characteristics that we may not have accounted for in the toolkit?


My login credentials work in other contexts (SFDC site, Data Loader, SForce Explorer, etc.).

I don't believe that there is anything unique about the network config. No proxy.

I tried it last night from home and got the same results, on an entirely difference configuration: Powerbook running OS X 10.4, fresh install of Eclipse 3.1.2, installed AppExchange plugin from the plugin site.

Let me know if there are any logs that I can send you, or anything else you'd like me to try.

I too am getting the same error. I did a fresh install of Eclipse 3.1.2 on my Linux box. When I
looked at the jar, which was grabbed by Eclipse at,
there was a reference to ...plugins/views/SchemaViewLabelProvider.class, but no SchemaView.
So I'm assuming it's not a classpath issue.

As far as networking environment goes, we run nightlies that fetch data through the 7.0 API
just fine...

Thanks, David

I spoke with Dave offline regarding this issue. Seems the Schema View that is available in the Views menu shouldn't be there at all. The correct way to get to the Schema Browser is by opening the appechange.schema item in the Package Explorer.


Todd Breiholz
Thanks Todd, that did it.
Are there any plans to enable access through a proxy with this plugin? Many businesses use proxies and it is a severe limitation to not have that included.
Fixed my issue. I was getting an error when trying to save S-Controls after turning on Proxy access in Eclipse. After running synchronizing the SControls folder, I can now edit and save the S-Controls again.
How exactly did you get the plugin to work?  I see no way to remove the AppExchange Schema Browser from the Show View menu.
Sorry guys - user error.  I was logging in with my evaluation Professional License, rather than the Developer License
how did you manage to remove the AppExchange Schema Browser from the Show View menu? 

Thanks in advance,