function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Error: {faultcode:'soapenv:Client', faultstring:''' is not valid for the type xsd:double', }

Can anyone explain what this means? This is a error occurs on an sControl that was working fine until recently. It was working on March 5, 2012. This error comes up when trying to enter a Value into a lookup field on an s-control.


Error: {faultcode:'soapenv:Client', faultstring:''' is not valid for the type xsd:double', }


This is some sort of javascript type casting error , 

Following are the sources of error like data issue, Please post your s-Control code 




Anil DuttAnil Dutt

I m getting same error


here is my javascript function



//Get Contact id
var contactId= "{!Opportunity.ContactId__c}";

//Get Opportunity id
var oppId= "{!Opportunity.Id}";

sforce.apex.execute("SendConfirmationEmail ","SendEmail",{contactId:contactId,oppId:oppId });


pleas tell me, what is wrong here?

Anil DuttAnil Dutt

Ok i found the issue, there was a space after SendConfirmationEmail like this


var result = sforce.apex.execute("SendConfirmationEmail ","SendEmail",{contactId:contactId,oppId:oppId });


i remove that it works fine


var result = sforce.apex.execute("SendConfirmationEmail","SendEmail",{contactId:contactId,oppId:oppId });




I am getting a similar error when i am trying to send a SOAP request to the salesforce webserivce from SOAPUI (dekstop tool). Strange this is that there is no soapenv:Client tag at all in the request generated by SOAPUI. it only has soapenv:Head and soapenv:Body tags.

Kevin WinnKevin Winn
I am running into the same exact error message.  As the administrator I am able to run this button successfully.  When I ask other users to click the button they receive the Error: {faultcode:'soapenv:Client', faultstring:''' is not valid for the type xsd:double', } message.

I have the following code embedded in my custom button:
{!REQUIRESCRIPT("/soap/ajax/22.0/apex.js" )}

var UCobject = new sforce.SObject("Opportunity");
UCobject.Parent_Opportunity__c = '{!Opportunity.Id}';
UCobject.AccountID = '{!Opportunity.SF_Account_API_ID__c}';
UCobject.CloseDate = new Date();
UCobject.RecordTypeId = '01230000001SLB7';
UCobject.Name = '{!Opportunity.Name}';
UCobject.Portfolio_Management_System__c = '{!Opportunity.Portfolio_Management_System__c}';
UCobject.Rebalance_Platform__c = 'Rebalance Express';
UCobject.Custodian_s__c = '{!Opportunity.Custodian_s__c}';
UCobject.Fix_Opportunity__c = '{!Opportunity.FIX_Opportunity__c}';
UCobject.Industry__c = '{!Opportunity.Industry__c}';
UCobject.LeadSource = 'Existing Business';
UCobject.c_Pricing_AUM__c = '{!TEXT(Opportunity.c_Pricing_AUM__c)}';
UCobject.c_Total_AUM__c = '{!TEXT(Opportunity.c_Total_AUM__c)}';
UCobject.StageName = 'Pipeline';
UCobject.Licence_Key__c = '{!Opportunity.Licence_Key__c}';
UCobject.Release_Track__c = '{!Opportunity.Release_Track__c}';
UCobject.Number_of_Licenses__c = '{!TEXT(Opportunity.Number_of_Licenses__c)}';
UCobject.Activation_Count__c = '{!Opportunity.Activation_Count__c}';

result = sforce.connection.create([UCobject]);
var newurl =

window.location = "/" + result[0].id;
alert('Could not create record '+result);

Any ideas on how to resolve this?

Thanks in advance for your help!
Sheila Northrop 13Sheila Northrop 13
Have you heard any more about a soluton to this problem? I am tearing my hair out trying to figure this out. I would appreciate any guidance on fixing this issue. Thanks.
Peter Kalina IBMPeter Kalina IBM
HI Sheila, did you figure out this issue?

I have the same error code when i am trying to debug list variable.

Thank you