function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

dojo 0.4.x support ?

I heard that dojo is going to be supported in winter '07, but I found that in my pre-release environment they only have the version of 0.3.1.
I'd like to use some of 0.4 features in my apps (like FilteringTable widget - in 0.3.1, only SortableTable is available, and it's already deprecated).
Is hosting any newer version of dojo ?


Winter '07 supports dojo 0.3.1.

Sorry, there are no plans to host newer version of dojo toolkit in winter '07. 

Ron HessRon Hess
It is quite possible to grab the dojo.js file from dojo 4.0 add the widgets (requires) you want (just append them), and drop it (large single file) into a S-Control of type SNIPPET, then include that snippet in your scontrol, and you can have the latest version of Dojo and it's served from Salesforce servers.

i've done this, post your questions if you try it and get stuck.

I have not tried this, but it seems dojo 0.4 supports cross domain script loading [1][2]. You can  include following script tag and then call dojo.require() to pull in the modules you need.

<script src=""></script>


Hi Ron,

I tried uploading dojo.js into an s-control snippet and then follow the directions for the Ajax toolkit on how to use
S-Control snippets like : {!INCLUDE($SControl.Dojo_Toolkit)}

But no matter what I do when I load my s-control it just displays the whole contents of the snippet. I´ve tried putting the include statement right next to the script tags, within my body tags but its always the same.

Any hints on what I might be doing wrong ?


Greg HGreg H
Hi Ernie,
Whenever I need to include a script file across multiple sControls I take the scripts and load them as an HTML sControl but exclude the opening and closing <script> tags.  Then I reference that specific sControl in the HTML of the sControl needing the included scripts with a line similar to the following:
<script src="/servlet/servlet.Integration—lid=01N400000008muq" type="text/javascript"></script>
Just make sure to use the salesforce id for the script scontrol in place of the red text in the code above.
Hope this helps,
> Chenaath,

Thank you for your information about dojo 0.4.1 crossdomain loading. It worked fine in my environment. But still I think it would be better to be served officialy by, because it depends's site availability.

Sure, I file a bug to update dojo toolkit.