+ Start a Discussion

Force.com IDE Deploy isn’t really working…

<meta http-equiv="Content-Type" content="text/html; charset=utf-8"><meta name="ProgId" content="Word.Document"><meta name="Generator" content="Microsoft Word 11"><meta name="Originator" content="Microsoft Word 11">

Hi There,


I’ve used the IDE Deploy once before and it worked like a charm.

Now I have a custom object, a custom tab, 2 triggers and a test class (I get 100% coverage) to deply from sandbox to production.


I Fire-up Deploy, plug in all the info, select the items to deploy, validate is fine, deploy is fine… BUT THERE IS ABSOLUTELY  NOTHING DEPLOYED TO PROD (from sandbox).


Any ideas?


got it working... the odd thing is when this was done from a "full" SFDC project it validates and says it's successful.
but when I did from a new/clean project w/a subset of objects etc... when I validated I got an error message. (there is a post on the wiki re/this trick)
which was a great thing as it pointed out a process/sequence issue of deploying objects/code.
once I serialized the deployment (first cust object, fixed a reference in Prod, then my triggers) all was well.
But Way O Way... didn't I get an error message when I tried to deploy from the full project?