function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Actions Plans V3

I've set up the Action Plans app, (

And following the documentation.

First up it would seem the documentation for setting up a Custom Object against the action plans is a bit out of date, but I can work around the slight differences there I believe.


However, I'm getting the following error when running tests. 

Class.ActionPlansBatchBuilderTest.runBatchException: line 316, column 1.


I thought this was down to some changes I had made being incorrect so I ran all tests on production. They passed.

I then refreshed the Sandbox, and once ready ran the tests there. And this error comes up immediately. 


Has anyone else encountered this problem with Action Plans, and found a work around?

Mr. AdminMr. Admin

Hi David - I've run into this issue myself, however I can' figure out a work around. I'm currently in the process of reaching out to Salesforce, to see if they will uninstall the application from our production org.


I am getting this error when I validate a change set:  In field: customButtons - no WebLink named Opportunity.Create_Action_Plan found.  I have already uninstalled Action Plans from my production org because of conflicts with change sets.  I can't find where this is.

Have you guys found a fix for this? I just installed Action Plans and tried following the documentation. I keep getting 3 errors during the deployment test and cant figure out how to fix it. 
Bud HaynesBud Haynes
Might be related to this thread....

System.AssertException: Assertion Failed: The Number Of Errors does not equal zero (0) as expected !!!: Expected: 0, Actual: 1 
Stack Trace: Class.ActionPlansBatchBuilderTest.runBatchException: line 325, column 1 

After I updated my user's email in sandbox, I did not receive the above error
Radha KandhukuriRadha Kandhukuri
Even i am having same issue when deploying the changes for custom object using the change set,  which user's email need to be changed. Any help is appreciated.
Bud HaynesBud Haynes
The emails for each user in sandbox have an "=" character in them and an "@example" string near the end. After going through all of the other differences between sandbox and production, the last item on the list was the user emails. So I updated my admin user email so it was the same as production (an actual email address), reran the tests and did not receive the error.