function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

receiving internal server error.

I've started testing the oauth2 auth via using curl on the command line (as described in another post in this forum).


I get all the expected warnings when using intentionally incorrect credentials (bad secret, bad client_id, etc).


However, when I use the correct credentials, (grant_type: password) I get an Internal Server Error (500 response):


An internal server error has occurred
An error has occurred while processing your request. The support team has been notified of the problem. If you believe you have additional information that may be of help in reproducing or correcting the error, please contact Salesforce Support. Please indicate the URL of the page you were requesting, any error id shown on this page as well as any other related information. We apologize for the inconvenience.

Thank you again for your patience and assistance. And thanks for using!

Error ID: 1854879326-13153 (-657290999)



Also, the link in the error message leads me to a page that tells me the data is missing. Does this imply that the REST pilot is not available in my instance (


OAuth is GA, and not part of the REST pilot, so its not that. Are you sending the request to ?


I was using


moved to  Same error.


It appears to hinge around the fact that I have "!" and "?" characters in the user password.


In attempting to test with intentionally bad passwords, I noticed that if I place either of those characters in any position (incorrect as well) in the password, that instead of the expected "invalid credentials" JSON message, I get the 500 internal error message.  For example: using simply "????" or "!!!!" as the password value.


I am URL Encoding the values, so it shouldn't be breaking the URL POST query format.


Perhaps OAuth won't accept those special characters as potenial password characters?  Did I find a bug, or is it an illegal password.  The current password works fine in the SOAP API as well as the SF web front-end.


Yes, I just discovered the same thing, this is a bug in the implementation. (for reference bug #W-846984)


Hah - excellent - glad to help out :)


Where can I find the bug tracker?


There's no customer facing bug tracker. You can log a case with support and tell then its in relation to that bug number if you need any more info. I'll also post here when the fix gets rolled out.


This issue with certain password characters cauing problems with the oAuth2 username/password flow should now be resolved.

Hemant Gulati 4Hemant Gulati 4

I am also reciveing the same error if i use my Sandbox credentials, It works fine with developer edition credentials.

Please let me know if there are any extra settings need to be done for sandbox.

Please help me in this.