function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

ERROR: Oops, Could not find an active worksheet

Hi folks,
Hoping someone might have seen this error before - after installing the latest version 6.16. I can login, but when I go to create a query, I get a pop-up message:
Oops, Could not find an active worksheet
I've done the usual un-install and re-install - still same problem.
I'd really like to get this fixed ASAP, so if anyone could help it would be much appreciated.
Ron HessRon Hess
This comes from the function sfDescribe() if no session is found / created.  Is it possible that your login is failing?
also, if there is no workbook and worksheet open, you could see this, normaly excel opens Book1.xls, and it is possible to close this then try to run the connector, which may give this problem.

if you have just upgraded, be sure to install the latest Outlook Edition as well

Hi Ron,

Thanks for replying so quickly.

There is definitely a blank worksheet open, and looking at the sforce connector menu, I see my login details greyed out and the logout session is enabled - I assume this means I'm logged in OK.

I tried using the credentials from one of my other demo orgs, and I get the same problem, so I'm pretty sure it's not related to my username.

I did have the PE version installed previously (which was working fine, then showed this same problem i.e. the oops message) which I removed, and then installed 6.16 and I also re-installed Outlook Edition 2.0.

I'm wondering if there could be some sort of conflict with any other components - is there any way trace this any further?

The Outlook Edition 2.0 stuff is working OK, Data Loader works OK,

I notice outlook editions is using the server and excel connector is using - is that right?

Also, if I use the wrong password, I do get a error messages, so again I'm assuming login is working.

Any help gratefully received.



Ron HessRon Hess
you may have a toolbar stuck from a previous version, i've created a simple macro to remove the toolbar and should allow a re-install to work correctly.

so, first uninstall the connector ( instructions in the online help / FAQ section)
download the attached JPG file, rename it ".XLS" then open and run the macro.

then you should be able to install fresh and hopefuly it will work.

the Outlook Edition should use the 6.0 SOAP API, so i'm not sure you have the latest version of that...


Thank you so much Ron, this solved my problem I was having which I posted in another thread. 

"A document with the name 'sforce_connect.xla' is already open.  You cannot open two documents with the same name, even if the documents are in different folders.  To open the second document, either close the document that's currently open, or rename one of the documents."




I am a different Ian H but having the same problem.  I can't seem to download the macro.  I have tried to manually delete the toolbar and add-on, then re-installed, but still get the same error message.



Hi Ron
Can't seem to get the attachment with the fix. Can you supply it in some other vehicle.
Ben PetersonBen Peterson
I'm getting the same error, "Oops, Could not find an active worksheet".  I've uninstalled/reinstalled the latest Outlook edition as well as v 6.16 of the Connector.

Is there anything you can do to help?  Or has anyone else found a solutions?

Thanks in advance for your help.

I am receiving this same error and unable to view or open this attachment to uninstall a prior version.  Can you please provide instructions on how to uninstall a prior version?  Thanks!