function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Installed but cann't use

Please help!
I installed the Excel Connector, however, when I click "Sforce Table Query Wizard", there was a error :
"The file could not be accessed. Try one of the following:
-Make sure the specified folder exists.
-Make sure the folder that contains the file is not read-only
-Make sure the file name does not contain any of the following characters:<>?[]:sforce_connect_for_pe.xla or *
-Make sure the file/path name doesn't contain more than 218 characters. "
Is there anyone can tell me what's wrong? Thank you!

I'm having the exact same problem.   I just posted mine under installation problems and then I saw your post.

Have you found an answer yet?

After more research, I found a thread that helped me.
I followed these steps and my Excel Connector in Excel 2007 is now working.
  1. Uninstall Salesforce Office and download it again to make certain you have the most recent versions
  2. Click the Office Button in Excel 2007 and choose the Excel Options button.
  3. Pick Add-Ins on the sidebar and then click the Go button at the bottom to Manage Add-ins
  4. Browse for the Excel Connector and make sure its checked.  Keep pressing OK until you are back to the main Excel.
  5. At this point, you should have the Excel Connector as a toolbar item in the Add-Ins section of the office ribbon
  6. Test it out at this point.  If it's not working, check a few things.
  7. Click the Office Button in Excel 2007 and choose the Excel Options button.  Choose the Trust Center on the left and then click the Trust Center Settings button.
  8. I have listed as a Trusted Publisher.  This is because I chose to always trust them when I run macros.  If they are not listed there for you, go to the Add-ins option on the left and make sure the first option (Require application add-ins...) is UNchecked. 
  9. Next check the Macro Settings and make sure they are set so you will at least get notified.  Mine is set to "Disable all macros with notification".  This will make sure I get the option to enable ones I want.
  10. Keep pressing OK to get back to Excel.
  11. In the Developer toolbar (if you don't see it, it's an option on the first screen in Excel Options), choose Visual Basic.
  12. When in VB, go to the Tools | References menu.  Make sure the sForceOfficeToolkit3.0 is checked.
  13. Click on the Add-In part of the ribbon
  14. Right click on "sforce Connector" and choose Delete Custom Toolbar
  15. Repeat steps 3 & 4
  16. Close Excel and restart the computer
  17. Run Excel
  18. Click on the sForce Connection in the Add-In ribbon and you should be prompted to log in.

Most of that is directly copied from the thread mentioned above but I added some steps that I did from other threads as well.  I am not sure which part of it fixed it, but after I went through all those steps it worked for me.

Would it be the same if we still using Excel 2002?  As I couldn't find some of the buttons and haven't figured it out. Any idea?
Thank you!

I'm getting an error saying the sfDescribeAndQuery macro cannot be found. This happens when I click sforce table query wizard.


Anyone experiencing this?



I added the connector to my various excel versions and the only time when I get error messages is when I do not have a clean file or when I login from outside and have not used the security code.

What I normally do is start a new Excel sheet and then connect to Salesforce.

Hope this helps a little.


I have struggled all day to get the connector to work for me - I depend on it several times a day and for some reason this morning, it was messed up. I tried all the usual stuff but nothing worked until I followed your excellent instructions.

Thank you SO MUCH!!!!!!!!!!!!!


Your macros are disabled for the xla to run.  You need to enable them