function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Installing Excel Connector - Macro error in temporary file

I opened the "sforce_connect.xla" file.  This is the file that later I saw a not that says "resist the temptation to open this file" in the installation instructions.  Now I am now unable to use the Excel Connector correctly, and I think that opening that file might be the reason for the following problems. . . .

I have tried installing and uninstalling excel connector several times since opening the .xla file by mistake.  Once I get it installed and the sforce connector button showing in excel, then when I select the Query option from it's dropdown, SF gives me the following error message:

" The macro "C:\Documents and Settings\sg0897039\Local Settings\Temporary Internet Files\OLKAC\sforce_connect.xla'!sfDescribeAndQuery' cannot be found. "

A similar message appears for all the options I have tried to select, just replacing '!sfDescribeAndQuery' with whichever option I tried to select.  I think OLKAC is my temporary files folder, but even when I finally access OLKAC, I don't see the sforce_connect.xla file in there.

Please help me :)


I had the same issue, and have resolved it just this morning.  I may have gone a bit overboard in my approach, but I feel it's better to be safe than sorry and my Excel Connect is working wonderfully now. 

My process involved cleaning up my PC, removing and reinstalling Outlook Edition and Office Edition and reinstalling the Excel Connector. 

Note: The Excel Connector instruction guide is not clear on this; but there is a different file name for the "sforce_connect.xla" referenced in the document due to the two program versions available.  I'm running Professional Edition, thus my file name is "sforce_connect_for_pe.xla".  I suspect that the name for the Enterprise Edition may be different.  Below, I'll refer to my file names specifically.

Prepping for PC Cleanup/Uninstalling:

Find your Temp directory: Mine is "Local Settings/TEMP" (do not delete any files yet)

Find your Add In directory: mine is Application Data/Microsoft/AddIns (do not delete any files yet)

PC Cleanup ( try to follow in order or you'll get error messages when opening Excel):

  1. In Excel: Uncheck the Add In for "Sforce-Connect_for_Pe" and hit "OK".  Then right Click in the tool bar area and uncheck the "sforce Connector" reference.  Close Excel.
  2. Remove the following program(s) from your PC: Salesforce Outlook Edition.  I also use Salesforce Office Edition, so I removed it also.
  3. Go to your TEMP directory and delete the "sforce_connect_for_pe.xla" file.  I also noticed that the file "sforce_connect.xla" was in my TEMP directory, so I deleted it.  ( I wonder if that file was created when I double clicked the "sforce_connect_for_pe.xla" file?)
  4. Go to your AddIns directory and delete any of the sforce connect xla files.  I deleted sforce_connect-for-pe.xla.
  5. Reboot your PC, probably not necessary.


Make sure all desktop programs are not running.

  1. Install Salesforce Outlook Edition
  2. Install Salesforce Office Edition (if you use that tool-an update was released for this solution on August 20, so good to reinstall anyway.)
  3. Download the Version of Excel Connector that you need and open the zip file (but don't double click on the ".xla" file.)
    1. Click to Highlight the ".xla" file, in my case, sforce_connect_for_pe.xla and click the "Extract" button.
    2. Extract it to your "AddIns" directory.  Then close the zip file.
  4. Open Excel, go to Tools->Add-Ins...", you may see the unchecked reference to your original "Sforce_Connect";  do NOT click the box to activate it.  Instead:
  5. Click on the Browse button which will open the AddIns location, choose (highlight) your ".xla" file and click the "OK" button.
  6. Click "YES" to the message asking if you want to replace the existing file.
  7. Click OK and wait for the "Sforce Connector" tool bar to appear.

You should be good to go.


I have the same issu.  I installed the connector about 7 months ago and it worked. I have since downloaded a new version of all sf office and outlook and the new connector.  When I ran each of the query options it looked in an old location.  SO I uninstalled EVERYTHING - even excel. I searched my drive for any reference to the .xla file and removed them all.  Reinstalled everything and the macros are still referencing the old location.  This is the message I get.

The following was enough for me:
- Uninstall the Excel Addin: Tools/Add Ins and uncheck sforce_Connect
- Delete sforceConnector toolbar: right click on the toolbars/Customize/Toolbars tab/ sforceConnector , and click the Delete button on the right
- Close Excel
- Clean any .xla reference in your document and settings
- Start Excel and Install the Excel Add In: Tools/Add Ins/sforce_connect, click on Browse
Kevin MulliganKevin Mulligan

You're the best!!!!. I've been going crazy trying to figure this out. Apparently, deleting the toolbar must be the trick since that is the only thing that I did not try. Thank you. Thank you. Thank you.
Thanks for those quick easy instructions, Luis

Removing it from the toolbar was the part I needed to Figure out - although it's different in Excel 2007 - You can just right click the drop-down button on the toolbar in the ribbon, and select Delete from Toolbar.

Do all the other stuff, browse to the add-in the CORRECT way, and bam!
- Delete sforceConnector toolbar: right click on the toolbars/Customize/Toolbars tab/ sforceConnector , and click the Delete button on the right
That step was key for me. I was just turning off the toolbar instead of deleting it.  Thank you!!!!!!
Marisol ThomerMarisol Thomer
I tried this and still have the same macro issue.  Is there something extra that needs to be done with Excel 2007?

Wonderful answere.Thanks luis.