function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Christina SmearsChristina Smears 

Excel Connector Not recognizing new install/not found

For some reason the excel connector for PE has stopped working and we desperately need some help.

First it worked great, but then it was moved. We then followed the instructions below, deleted all signs of the excel connector on the computer, restarted, re-installed the excel connecter, and did everything possible - but we can’t get the excel connector back to working.

Each time we re-install, re-add the Add-in (or replace it), and then go to re-add the sforce connector toolbar, it gives us the same error that it cannot be found and is still looking for it in the original place it was – the first time it was installed.

Is there any way to fix this?

We’ve been trying everything on the discussion board, including the instructions below from the FAQ and still cannot get it to work.

I already tried this:
Open Excel
Click Tools, Add-Ins
Uncheck the sforce_connect checkbox, click OK
Close Excel
Open Excel again, if the "sforce_connector" menu bar is still there, right click on the tool bar area of excel, uncheck the sforce Connector check box
Close Excel
Open Excel
If the bar is gone and the Add-INs list is showing the add-in as unchecked or gone then you can re-install the add-in from the new file location of the XLA, see the install instructions on the web (


Thanks so much!

Ron HessRon Hess
The problem may be that the connector toolbar is added when the connector is installed, yet, it is not moved or removed when you move the XLA file.

to solve this I've written a simple macro that deletes the toolbar, download this:

then, open that xls file and click the remove-me button.

Now you can re-install the connector from it's new location.
best of luck!

Thanks, Ron! I got click happy and installed incorrectly (just clicked on the xla file). This finally fixed it for me.
Sai LavuSai Lavu
Thanks Ron. The tool came in handy.
Scott 99Scott 99


I recently updated to MS Office 2007. Now Excel Connector no longer works. I fear I moved something upon reinstall. (Note: we successfully installed a fresh Connector on another machine running 2007).  I can successfully get to the Login/Password screen. Upon entering my password, I immediately get a "Microsoft Forms Error: Could not load an object because it is not available on this machine." Upon selecting OK, I get the error "Ooop, Could not find an Active Worksheet." I get those same errors when attempting to select any function in the Connector menu.

I've deleted, uninstall, reinstalled, and removed the Connector Add-in from the Custom Toolbar (both on my own and with your macro). I've uninstalled and reinstalled all instances of both Excel Connector and Salesforce Office Edition. I installed Salesforce Office Edition 3.0 (referenced in a prior post) although application details now show version as installed. We even reinstalled Excel.

Clearly I'm missing something. Any advice?

PS. We use Salesforce Professional edition.

Not sure if someone replied, or if you've figured it out since posting this. To avoid getting the "Oops...Active Worksheet" error, open a new excel worksheet before attempting to use the connector tool. That should solve the problem.

I have been using excel connector from several years. just today it started the same error from OP above.  Tried everythign. Doesn't work. Any ideas?


Tried opening a new document as per Jenell's suggestion below. no use. 


Also I doubt this could be a registry issues. Does anyone know how to remove regitry entries for excel connector on windows xp?