function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Duplicate Field In Query

Hi. This is the problem I'm having:

- I'm in the Connector.

- I select Sforce Table Query Wizard

- I select "Account":as the table to query

- The custom field I want to select for "Account" shows up twice

- Even if I only select it once in the wizard, the Connector adds it twice to my worksheet

- If I try to run the query with this custom field added twice, I get an error about dupicate fields (exception code 5077)

- If I don't use this custom field but rather any other native or custom fields, the Connector pulls the data without error

Does anyone know what the cause of this duplicate field in the wizard is? As far as I can tell, and I created it, it's a regular custom text field. One possible clue is that this custom field is visible in the wizard next to all of the other custom fields for Account as it should be. But the duplicate of this custom field is right underneath "Account ID" in the field list.

A second clue is that when I mouse over the cell with the column header for this custom field, its name has an underscore "c" appended to it - like so: "Identification_c." However, if I mouse over the other field names in the spreadsheet, it's only the field label (e.g., "Identification).

And this reminds me that I did do one unique thing to this custom field when I set it up that I didn't do to its brothers. I made it a required field in order to save the record.

Anyway, suggestions on how to include it in the query are appreciated because it is a critical field.


I am having the same problem.  Has there been a recommended solution for this?




I was able to delete the duplicate field heading within Excel (by deleting the column), and then my data downloaded fine.


-- Julie

Like Jcrowner did, I just found the cell that was causing the duplicate error, right clicked on it and deleted it.  For some reason or other, when I selected the fields to display I would end up with the first being a "Plan ID" and then mixed in with the rest a "Plan ID."

Once I removed the second instance of "Plan ID" I clicked on cell A1, went to the Excel Connector toolbar and clicked on the "Query Table Data" button.  After that everything loaded correctly.
Hi - just wandering if anyone or is there a permanent solution to this issue.  My query is running against a custom object not standard object.  I've tried deleting the duplicated column and tried to run the same query without any success.  The query will re-insert the same duplicate field back into the same column.
I had this problem too.  By going into the options and the Use Names tab and selecting the only checkbox in there, this problem went away. Sure the colum headings become the api names and may be uglier but it all works fine for me.
I decided to use the Dataloader instead of the Excel-Connector.  Was able to get my query fine without any hitch. 

In our case that the option in Use Names tab is turned on and querying to Account, the same error occurred.
And meanwhile, in case of the option is turned off,  the error didn't appear and a result successfully returned.

It's strict truth that duplicated fields name in both cases isn't there, though.

What problem did I have?