function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Excel Connector error 5103

I've been trying to use the Excel Connector for the last two weeks to manage the data in our organisation, but I'm having a problem where I get the following error in Excel which is preventing me from using this tool:


Error Generated by request::An internal server error has occured while processing your request.

ExceptionCode : 5103

The first couple of times I tried to use Excel Connector it worked fine. However I then started seeing this error every time I tried to use it - the error appears after I put in my password in Excel Connector and click Login.


We are on Salesforce Professional. I have tried uninstalling and reinstalling the toolkit and connector, but it hasn't made a difference. I'm using Excel 2010 32-bit on Windows 7 64-bit.


I can log in to Salesforce in my browser on the same computer.


I've checked that IE is not in Offline Mode, and verified that Excel can actually connect to the internet (pinged a URL using VBA script).


I've tried disabling my antivirus (MSE) and windows firewall.


I've tried changing the server url as suggested by this thread (had to modify registry keys to do this as that field was not editable in the connector.


None of these resolutions worked.


Has anyone experienced and managed to resolve this, or can anyone suggest any other possible resolutions?

Best Answer chosen by Admin (Salesforce Developers) 

I had the same problem.  First make sure you are not locked out of SFDC (since you tried to log in so many times), and if not, then try adding your token the end of your password.  This worked for me.

All Answers

Michael DuhanMichael Duhan

I am having the exact same problem.  I am able to see the successful login in my user profile, however when I run a query it throws this same error.


I am on an unlimited license, Windows 7 64bit, Excel 2010 64bit.  I have not been able to determine the error, but it appears to be URL based from the error name.  The only difference from your error code to mine is that the URL for mine includes the 16 digit SF ID for our company's instance of Salesforce.


I do not know how to resolve this, but I am trying solutions and hopefully will find something.


I too am seeing this exact same error message in Excel 2010 with Salesforce Professional Edition.  If anyone has any insight, please post!


I was receiving the same error this morning. I was able to get around it by selecting fewer columns to query. I'm not sure if the issue was a column that had data that Excel connector couldn't return or if I had just selected too many columns. Hope this helps someone.


Number of columns isn't the problem for me -- I can't even log in when starting from a blank workbook.


I am periodically getting the same error (well, same text but exception code: 500, not 5103) - it just started today (12/21) and I use this tool nearly every day.


Some things I've tried:


-changing the server URL at login. Personally, I get the error pretty consistently at 6.0, less often at 16.0, but haven't gotten it yet at 13.0


-using "Query Selected Rows" and custom formulas (=sfemail(email) for example) seems fine, but Query Table Data fails pretty consistently unless I'm returning a small number of records


-logging out and back in to the same server URL after getting the error doesn't do much


-checked my system overview to make sure I wasn't butting up against any limits (I'm not)



I've also noticed that everything I do from the connector is slower than normal. I'll be watching this error closely... paddyb1, sorry to not have a solution but know that there are others on the hunt for one!.


I'm having the exact same problem.  I'm getting it when I set a query parameter that uses a Date field from a custom object.  I've tried logging into the connector using all kinds of versions (6.0, 9.0, 13.0, etc.) and I'm getting the same error message.  The error goes away when I remove the date filter.


Same issue w/ updating records. Only work around seems to be to use the Data Loader.


I had the same problem.  First make sure you are not locked out of SFDC (since you tried to log in so many times), and if not, then try adding your token the end of your password.  This worked for me.

This was selected as the best answer

Problem still occuring, however the above post prompted me to try again.


I got the same error, but on checking the login history in Salesforce I see an entry with the status "Failed: API security token required". Lo and behold, I try the Connector again, this time entering my security token and it works!


I am fairly sure that I tried this before without success. Also I am fairly sure that I remember being prompted by the Connector to enter my security token at some point previously. I recently added our office IP as a Trusted IP in Salesforce. It could be that this turned off the prompt for the security token in Connector, but Salesforce still requires it to be entered.


In any case, if you are getting the 5103 error message, try appending your security token to your password in Connector when logging in. Hopefully this continues to work for me!


Weird... I have no idea what happened, but I'm no longer getting the error message... didn't have to enter my security token or anything.


Time heals all wounds, I guess :)


I'm now getting this same error as well. I use the connector daily including this morning and it worked fine. I do not see any login errors to my instance, just successful logins. I've tried adding my token as well with no success.

Phil BriningPhil Brining

Now this one really has me foxed.  I'm using the Excel Connector to query a custom object Purchases__c which is related to Contacts.  The excel connector returns the 5103 error only when certain fields are selected.  I don't get API errors using other tools for querying like Jitterbit or DataLoader.  I'm at a loss why the excel connector fails on certain fields where the other tools don't.


Solution did not work for me regardless of whether or not the token was included.


I'm also having the problem at the end of several days of extensive Excel Connector usage without a problem. The problem is probably not with the Excel connector code as the reported error is actually coming from the servers. The temporal nature of the problem could point to a transient problem on the servers or some change to the underlying Excel software triggering a problem after extended usage.


If I had to guess though, I'd say there's something not right with the APIs on the server side. I don't know if it's just the older APIs as I only use the Excel Connector. I don't think anyone has reported this error with the Data loader as far as I can tell, which suggests it is the older APIs that are problematic. only officially commits to supporting the current API version and two older versions. That said, given the significant number of Excel connector users and the absence of any equivalent replacement, the older 13.0 and 16.0 API versions would still be actively used as a result; they should see this in the API usage statistics. Hopefully someone on the server-side just accidentally broke it and it's an easy fix.


The token resolved the problem for me too.


I think amen-intech is right. When I attempt to query and get an error (which doesn't happen all the time but still does periodically) I usually get a link in the error message, something like[INSERTIDHERE]


If I try to go to that link, it's often an error saying 


HTTP Error 405

Problem accessing /services/Soap/c/16.0/[INSERTIDHERE]. Reason:

GET not supported


Salesforce must be messing with something creating this result....

Ron HessRon Hess
I believe that this error message can be caused by duplicate fields in the columns list. If you have this error, reduce the number of columns to ones that are unique and see if it goes away.

Also you can turn on API names and see if there this will allow you to see if duplicates are present.

I suggest trimming down to something very simple like

Id, Name

and see if this works, then add back columns one or two at a time and you may have luck if the problem is duplicate column names

Brent ABrent A

I reset the internet explorer settings and it fixed the problem for two different users.   Windows XP, IE 8:  Tools > Internet Options > Advanced > Reset


Hope this helps! 




Brent A

Paul FischerPaul Fischer

I am getting the same 5103 error. I receive the error not on login but upon querying the table. The error is followed by an error thrown by the Salesforce Excel Add-in stating No data returned for this query. 


The funny thing is that I can query from the Accounts table with no problem. It is only when I query Opportunities that I receive the 5103 error. The error renders regardless of which server I am connected to. I have also played around with choosing which fields to display, which filters to have, etc. It does not appear to make a difference whether they are standard or custom fields that I display or filter. I have also tried playing with settings in Internet Explorer as the previous user mentioned.


I am pretty bummed because Opportunities is the only thing I report off of. If anyone has any tips it would be greatly appreciated.


Edit: I have been using 32 bit Microsoft Excel 2007 with the addin. I previously installed it with Office 2010 (tried both 64 and 32 bit versions. I have also tried password + security token versus just password and log in both ways no problem.  If I can get this working it would save me 20 hours per month!


I haven't figured out the root cause of the issue as yet, but I can also confirm that resetting the IE settings reduced the occurance of 5103 errors related to authentication failures to just about nothing.


the actual error number 5103 is being thrown by the Outlook connector DLL and can be thrown for multiple backend error failures (just to add to the troubleshooting challenge). In my experience of the 5103 error I don't normally even get to the "no data returned for this query".  I can confirm that I can do an Opportunity object lookup without issue on my system, so your problem would appear to be the same transient issue others have faced.


I would recommend following the IE reset advice stated above and confirming whether it's still a problem for you.



Paul FischerPaul Fischer

Thanks for your response. I reset everything for all 3 versions of IE that I have installed (64 bit, no addons, and regular) to no avail. I wonder if it's something on the Salesforce side? I should have enough API calls available, and I don't think any of the workflow rules I have set up for opportunities should be interfering. I'll stay tuned. Thanks!


Can't offer any advice except to relate what has continued to work for me when it bugs out:


  1. Log out in Excel Connector and then reauthenticate
  2. Reset security token in Salesforce
  3. Make sure that I am correctly appending the security token to my password each time I authenticate the Connector
  4. Make sure that there aren't any duplicated fields/incorrect field names created by the Wizard - there is a custom object (created by an App) which I report on, for which the Connector creates bad field names.
  5. Reboot my computer and try again.

Even after all of the above I still have another custom object which I cannot query using the Connector.

The 5103 error appears most often when it thinks I'm trying to pull TOO MUCH data out of Salesforce. I have to reduce the number of columns I'm asking for or use to query the data directly.


Everyone on my team that uses the Excel Connector is getting the 5103 message. It's nothing to do with what's being pulled back, as far as I can tell - and I've checked. I always use my security token, but those that don't need to have the same problem as those that do. This has been going on for about two months.


Fundamentally it doesn't stop the connector running, it's just annoying having to log in twice. Strange though, at one point it would randomly ask to log in on random connector runs, and occaisionally later in the day. It's calmed alot over the past month.


Unfortunately in my organisation our settings are looked down, so I can't reset the IE cache without placing a call to IS. However I'm willing to give that a try, and I'll report back if it makes a difference. It probably doesn't help that until much later in the year, we're still stuck using IE7. I'll report back if it makes a difference.


We have been suffering from this problem since the beginning of the year. But we get the 500-code instead of 5103. In jan-feb it was very frequent, then  it calmed down but last week we have been getting it a lot again.. Users either have to login twice or, in some cases, close Excel and start it up again. Then it (most of the time) works.


We mostly use API 14.0 

All users work from an authorized IP (so no security token required)

The selection of columns does not seem to have any effect.






Everybody can reset security token and try again, it's OK with me


Hi Everyone,


I am having the same mistake as Paul Fischer previously metioned. And only receive the 5103 Excel Connector error message when i try to pull data related to the Opportunity Field.


This issue has now been mentioned and talked about for more than 2 months. Does anyone know what i can do or if any of the suggestions (apart from Token and relogging in as this works well in periodic error messages) really work with this particular issue?


Especially with the tip about resetting the IE settings. What if i use Google Chrome more or Firefox. Would i have to reset them too?


Thanks for your input gyus!


I have found the IE reset to work, albeit with lots of side effects. I believe Excel uses the IE engine as the underlying browser module, so chrome and firefox shouldn't be relevant to this issue. In my case I have chrome as my default browser and resetting the IE settings did reduce the prevalence of 5103 errors, although I do still get them from time to time.




Just adding my 2 cents.   I've just wrestled with this problem for 2 days, finally tried clearing my internet history in chrome.  That fixed it - no more exception 5103.  I don't know why the browser matters or why clearing chrome fixed it since I use chrome, firefox, and IE.


Error Code 500: I have experienced those symptoms when exceeding our total number of allotted API calls in a 24 hr period.


Two ways Google'd suggested to check for API overages:


  • Click on the Reports Tab, then click into the 'Administrative Reports' folder and run the 'API Usage Last Seven Days',
  • Under Setup, Click 'System Overview' for an API dashboard like component of the last 24 hours.

Note: May need 'Modify All' type permissions to view the above features.


Hi, thanks for your reply.

It doesn't look like we've used too many API calls. Also usually if we try again (sometimes only after restarting Excel), it does work. I guess the 500, just like 5103, is more like a general catch-all error message. Too bad we can't see more details, Maybe in the new Office Toolkit for Office 2010 (it that's ever coming...)


From what I have noticed from some testing is that special characters in the field label are what cause the query to fail.


Example:  -  /  %  (  )     etc.


By changing the query to use API values really helped us out by making it possible to query the entire object.




For me it was the fact that the password on the account I'm using to connect to Salesforce had expired.  I tried to log in to a regular interactive session with that username/password and received a "reset your password" prompt.  I wonder if the API, somehow inside it, received the same message.  In any case I reset the password and I'm back in business.


FWIW, I was trying this on a new box and pulling my hair out.  I'm out of town and working remote, so I checked my old PC from home. 


The new install of the connector was trying to connect over version 13, my PC at home was on 6.0, so I was in with this: 

Not sure what functionality I'm losing via that change. 

I could solve this problem Uninstaling and reinstaling the connector

Andy C (i2o)Andy C (i2o)

I have just been trying to get to the bottom of this, and from what I can find out, PE does not have API access - though there may be a PE version of the Excel Connector that can gain access through it's own certificate?  More investigation required ... 

I tried to run the DataLoader, but it looks like this has the same issues - but at least it returns a more sensible error message!

Does anyone know if SF can activate the API for PE?  It looks like it used to work in the past???


Receiving error 5103. Have never had an issue before. I try to go into connector table query wizard and when I enter my user name and password,k even with security token, I get Error 5103.  Spent about an hour on the phone with SF tech support. Still no resolution. My logs show successful logins Anyone have any ideas.


I too got the Exception code 5103 using the Excel Connector 13.0 for the first time today. I have used regularly up to today without problem. Today I got the error but was able to login after adding the security token to my password. I am using Windows XP and Excel 2010.

We have tried this on 4 machines here. XP Office 2007, Windows 7 Office 2010. Different logins, with no token, with token. No success we keep getting Error 5103. This is huge issue for us as we rely on the excel connnenctor to impor tour price lists. Developers any idea when this will be fixed???


We have tried this on 4 machines here. XP Office 2007, Windows 7 Office 2010. Different logins, with no token, with token. No success we keep getting Error 5103. This is huge issue for us as we rely on the excel connnenctor to import our price lists. Developers any idea when this will be fixed???




Andy C (i2o)Andy C (i2o)

Which SF edition are you using?


We are using latest version Summer 2013
Andy C (i2o)Andy C (i2o)

No - edition means "Professional" or "Enterprise" or "Unlimited" etc ...


Professional. We have used Excel Connector in the past with no problems.
Andy C (i2o)Andy C (i2o)

I think they may have changed the rules??? API access is not available by default for PE - but you can ask to have it turned on ...  Or I believe there may be a special PE edition of the XL Connector that will work ???  Let me know because I haven't tried that yet & may yet need to! :)

Have you changed the api version? Still don't know why that works, but it
seems to "fix"the issue for me.
Tried that and it still did not work.

We got it to work by using the pe_winter11 connector.


I'm using version 16.03 of the connector and have been running into this same 5103 error.  In my case it was happening every time I would try to filter my results using a Date field.  It turns out that the connector is translating all Date parameters into DateTime values which will cause the query to fail if the field is not a Datetime field.


I was able to make this small adjustment to the connector to resolve the issue.


Open the Excel VBA IDE and find the 'utils' module in the sforce_connector project.

Find the sfQueryValueFormat function and replace this line...


sfQueryValueFormat = Format$(vlu, "yyyy-mm-ddTHH:MM:SS.000Z")


...with this section of code...


If (typ = "datetime") Then
  sfQueryValueFormat = Format$(vlu, "yyyy-mm-ddTHH:MM:SS.000Z")

  sfQueryValueFormat = Format$(vlu, "yyyy-mm-dd")
End If


You'll need to save your changes as a new add-in (.xla) file and then change the add-in that your Excel sheet is using to the new modified one. 


Hope that helps.




I was ennoyed as much as everybody migrating from XP to windows 7 and Excel 2010

After re install of Excel connector, I did have the famous exception code message.

But when seing the server name  , I did try to replace 13.0 by the new API version 24.0 so


.... it works.

Now when I launch the connector, it reverts back to 13.0

anu idea ?





To my knowledge the connector will only work with API up to 16.0. 

The 13.0 is hardcoded in the VBA code so if you want to change it, press ALT+F11 and edit the code. Don't forget to save after editing.

And be careful when changing the code because it might break the functionality if you change the wrong thing.

Juan SpagnoliJuan Spagnoli
I think Ron Hesse is right, maybe the issue is caused because directly or indirectly we are repeating fields in the query. For example, querying two fields: Account.Name using a lookup field (Account.Name) and a formula field that do the same thing (Account.Name).
In case of Excel Connector, i noticed that when i have repeated labels for different fields, the plugin tried to get both. Be carefoul about that.
I was also haveing the 5103 error but read something in one of these posts about security that got me thinking.  I've now added "https://*" to my Trusted Sites on my web browser and have been using Excel Connector without getting the error message.  

 this problem really drives me nuts - do not know what causes it but after changing the security exceptions in my browser and the n logging out of ecel it worked
You are not the only one going nuts.. And to top it all the Data Import Wizard is throwing weird exceptions as well. I guess I'm better of spending a week entering all data manually.

I had some success and it was quite simple. Hope some gets some value out of it.

Windows 8 64-bit
Office 2010 (64-bit) - still better than office 2013

1) Changed the URL to:
2) reset my Security Token
3) logged in with normal user name
4) Entered password
5) Added Security token to the end of my password.....

Works fine and loving what I can do with it, but as a lazy BA, I want to now work out how I can use this to create 30+ Custom Objects with over 1700 this the tool to automate the whole process or am I about to spend weeks on the train adding field after field after field after field after field????? Any ideas?


I had the same issue.  I was able to resolve it by loging out in the excel connector, logging back in, but selecting advanced, then updating the URL to point to /16.0 instead of /13.0
Thanks kirksievers!  Your solutions fixed this for me.  I vote yours as the best answer!
Andrianjaka RAOELINAAndrianjaka RAOELINA
I have the same problem as Paul,
I tried to change the API 13.0 to 16.0, reseted the configurations of my internet browser, reseted token, etc...
nothing has changed,
i have to update 7300 products,
need help please,
Mike McGeoyMike McGeoy
Okay, new twist on the same old problem...
I am getting the 5103 error only when I attempt to access the Opportunity object (?)  I can log in and query successfully on Accounts as an example but any query I try (and I've tried lots of combos) immmediately returns the: Error Generated by request: An internal server error has occured.....Exception code: 5103

Tried changing API from 13.0 to 16.0 same results
Tried adding https://* to Trusted Sites
Tried a number of other solutions that worked for others in this thread...

Anybody else have this specific kind of issue (only certain Objects fail) and if so, anything you did to rectify the situation.  The bizarre thing is that I can query Opportunities with DataLoader no problem...

Thanks in advance!
Mike, Have you tried going higher on the API version? we're on 32, but try 29 for now.
I believe this happens because of duplicate field labels in salesforce. I have 'Account Id' - the 18 digit salesforce id field and a custom field with the label 'Account ID' and when I try querying both at the same time it gives me the 5103 error. Try editing one of the field labels in salesforce or querying the fields separately.
Derek M HughesDerek M Hughes

I have a started getting a "GET Not Supported" error on ONE of the orgs that I usually connect to.  The others are working fine.

Does anyone have any ideas on why only one org causes this issue?


I got the 5103 error.  I did not know what the security token was until i looked it up on salesforce help.  Click on your username in top right hand corner.  Go to my settings.  Click personal, then reset my security token.   Follow the directions from there and it should work.  That is how I fixed my problem.
Peter DziembowskiPeter Dziembowski
[aprilrcampbell] aprilrcampbell's solution worked for me - added security token to the end of password and was able to proceed as normal.
Jennifer TrujilloJennifer Trujillo
03/03/2016 - Error went away - Delete Duplicate Columns:

I selected the columns containing the items to be queried and selected the entire row. I then proceeded to the Conditional Formatting area of excel (Home/Styles>Conditional  and selected "Highlight Cells> Duplicate Values".
The formatting helped show me which columns contained the same API's/Column name duplicates. I then deleted the duplicates and the error went away once I tried to query any data.

Hope this helps!
Gabriel Carvalho SoaresGabriel Carvalho Soares
Hello, I'm receiving the message "Error Generated by request:: Not Found ExceptionCode: 5103".
I was using the SforceConnector normally last week, but today I can't acess the data.
I'm not blocked and I'm using my password with my token, like I always did.

How can I solve this?
Kelly KKelly K
Gabriel - we're having the same issue for all users in the org. Most I have found so far is that this is likely related to the Salesforce diablement of TLS 1.0, other services* on April 7 - April 23, 2018.

I'm trying to find if there's a string or something we can update in the macro to address this, but no luck just yet.
Robert NudoRobert Nudo
Hello Kelly,

I was getting the same error (code 5103) in Excel Connector.

In the Login, under Advanced Settings, I changed the following Server URL:



Was able to use my regular password without the token.

Worked fine.

Hope this can help.

Bob (Tempe Az)
Kelly KKelly K
Thanks Robert. As you posted that, I was just relaying the same message to my users. :) Glad we came to the same solution. 
Gabriel Carvalho SoaresGabriel Carvalho Soares
Thanks RObert, that worked for me.
Thanks, Robert! I was having the same problem today and your solution worked for me.

THANKS ROBERT! That worked!
I tried rebooting, loging out, logging back in with the same error. This new link worked, I wish admins would alert us.


Justin KrugerJustin Kruger
Thanks Robert. 

Salesforce must of changed something over the weekend. 
Ashraf TalukderAshraf Talukder
Thanks Robert Nudo. Replacing www with login worked.
Andrea WallaceAndrea Wallace
Robert "The Bob" Nudo for the win!!!  Thank you!!!
Ron HessRon Hess
So, cool that this thread is still alive and helping people !
Raquel SierraRaquel Sierra
Thank you much @Robert Nudo! For us also worked. Easy! Replacing www with login and ready.
How do you change the URL?  When I am on the log in screen I cannot click on Advanced nor can I change the Server URL.  When I select Salesforce Connector, Option, Advanced Options, it will not let me click on the Server URL field.
Kelly KKelly K
Odd. You typically should be able to click Advanced and then it allows you to edit the URL there. 

In the Advanced options, you do have to click the checkbox first in order to access the field.
User-added image
Philippe FerronPhilippe Ferron

If you are unable to change the server url from the advanced options (due to your checkbox of your advanced options being greyed out), you have the possibility to load it from your windows registry by creating the following entries.

1 - Run in the Start menu and run the regedit command in order to launch the registry editor.
2 - Then, create a key HKEY_CURRENT_USER\Software\Opensource\ServerURL with the value
3 - create another key HKEY_CURRENT_USER\Software\Opensource\SetServerURL with the value "True"

Now, when you start excel, the excel connector will load the server url from your registry windows into your advanced options panel by default.
Explanation: the VBA code of the excel connector was written to check and eventually load if a server url is set in the windows registry by default.
Sarita NaoremSarita Naorem
Hi I have tried changing www to Login in the url. Then insert is working but not update. don't know what to do. Any suggestions!
pradeepa jgpradeepa jg
Please suggest me the steps to get the above mentioned advanced option tab.
Tried top navigate from File-->options--> Advanced tab on excel but it looks totally different
Ashraf TalukderAshraf Talukder
Hi Pradeepa, it’s not Excel’s Options. You have to go to Add-Ins tab and find connector’s options. I am attaching a screenshot. 

User-added image
Sarita NaoremSarita Naorem
hi This is the error i am getting while trying to update the data in Salesforce. the code underline is highlighted so any idea how to fix the issue.   Please help me. 

Public Function Retrieve(sels As String, idlist() As String, entityType As String) As Object
    ' make sure id list has no blanks
    Dim i%: For i = 0 To UBound(idlist)
      Debug.Assert idlist(i) <> "" ' bad things ...
    Next i
    Set Retrieve = sfApi.Retrieve(sels, entityType, idlist, False)
End Function
Sarita NaoremSarita Naorem
Suddenly when I change the Url , its working. 


Ashraf TalukderAshraf Talukder
Great! 13.0 is old API anyway.
pradeepa jgpradeepa jg
Thanks for detail, however the URL configuration mentioned above is not applicable for "connect for office" tool it seems.
Kelly KKelly K
"Connect for Office" has been deprecated along with TLS 1.0. There's a big banner on the install page for it.

When Salesforce disables TLS 1.0, we’re ending support for Connect for Office. This change means that there’s no guarantee that Connect for Office can establish a connection between Salesforce and Microsoft® Word or Excel. Even if sales reps can establish a connection, Salesforce no longer provides support or maintenance when there’s an issue.

This thread is talking about the "Excel Connector" which is not supported by SFDC, so we have to get creative on making this older tool work as SFDC updates their architecture.
pradeepa jgpradeepa jg
Thanks, yes it is deprecated longago, we are using it with woraround so far, since May2 probably that is the time TLS Changes also pushed in, workaround also stop working. Just waiting if someone have fix for workaround :)
K KampmannK Kampmann
I have Office 365 and just installed the Excel Connector but it does not work. Get the 5103 Error. I changed the url for the SF login to but that did not make a difference. Still get error. Hoping someone can help.