function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Oded MillerOded Miller 

developers console will not load

I'm using MS Windows 8.1 with Google Chrome Version 35.0.1916.114 m
I have a free Salesforce trial version

From the "My Name" menu I chose "Developer Console".
I get a new window Developer Console with the "Loading workspace ..." progress bar.
The progress bar gets hung at about 50%.

Any advice?

Odeddevelopers console will not load
Phillip SouthernPhillip Southern
Oded is the consistent regardless of environment?  Have you tried this in another production instance or a developer edition?
Oded MillerOded Miller
Hello Phillip.

Thanks for the prompt response.

I am using a free trial version. As far as I understand this means one single environment.
Do you know of a limitation to using the developer console in a trial version?

Regrads, Oded
Pranshu SharmaPranshu Sharma
Same here... I'm also not able to load the developer console... Any answers are highly appreciated...
ritendra singhritendra singh
SAme issue is with me as well. I have tried on different browsers, but issue still remains. Even, when I tried to create the project in Eclipse, I am not able to connect to salesforce server. It seeme to be an issue with firewall an dproxy, but after doing proper changes, it is still there. Can someone put their answers if they have figured out this issue. Any pointers will be appreciated. 
Vinay SinghalVinay Singhal
I'm facing the same issue. Using salesforce trail version summer 14 - profession edition. Is there any limitation like can't use developer console with profession edition
Sarun KumarSarun Kumar
Same case here. can you please suggest what to do now?.
I think I found the problem... I signed up simply as a regular account at I later signed up from another url and with this account my developer console started opening instantly... Having smooth drive in salesforce so far... I strongly recommend test drive on salesforce by completing the step by step tutorial @ 
Daniel NowocinskiDaniel Nowocinski
Solution that worked for me is (IE instruction, i'm sure it's similar for all browsers) : when you see developer console page with "loading workspace..." message, right click on page, go to the properties | certificates | Install Certificate and then complete the certificate installation with wizard, after that reset your developer console.
Frederic Lapierre 5Frederic Lapierre 5
I had the same issue. When I was opening the developper console from my organization menu, it will fail to open and keep loading for ever.

So I just copy the https link (https://YOUR of the loading page and re-open a new web page, copy the link and the console this time open as usual in a new page. I put this link in my Favorite in Chrome Broswer in case of this issue reappear.

Work for me.
im having an issue with developer console fully loading and i get an error saying 'b is not a function, main.js:392' 
im using chrome on mac os x 
Ganesh MGanesh M
I am  having Same issue with my Org. when click on developer console. it is not opening. it is showing as below of loading page. please help me on this. User-added image
Dannielle GivensDannielle Givens
I copied and past the URL into another page as suggested by @Frederic Lapierre 5 and was able to gain access to the console where I can go in and delete the APEX Class that was giving me the issues. I was looking to create a Lightning Component through a Trailhead exercise. 
Mohd Tariq 9Mohd Tariq 9
Try to copy popup tab developer console url and paste this url in normal tab. It should work
Abel La Rosa 3Abel La Rosa 3
Thanks Frederic, paste the url in a new window worked for me too
Pablo Ledesma 8Pablo Ledesma 8
Thanks Frederic.
Worked form me too
David Egan 9David Egan 9
Chrome opened a new window and page timed out.  I copied and pasted into my open window and the developer console opened!  Trailhead and My Playgrond froze but I could use the console and just re opened TH and MP.   
Matt KeefeMatt Keefe
I ran into the same issue (same as image posted by Ganesh M), and copying the URL and pasting into a new tab worked. There must be some issue with the popup when certain resources/components are open in developer console.

Neeraj SolankiNeeraj Solanki
Thanks Frederic 
Its worked for me.
Rujuta HonraoRujuta Honrao
Thanks Frederic, it helped me. 
Ankit Sharma 7Ankit Sharma 7
Copy URL:  from Developer console Page and then paste it into a new tab in your browser.It will work fine.

This is only temporary problem and you can open developer console in new window the next day you log in
pallavi reddy 54pallavi reddy 54
Thanks Frederic, it helped me. 
Frederic's solution didn't worked for me. Is there another way to resolve the issue?
Jayesh KapadeJayesh Kapade
Hello everyone,
After a lot of struggle, I have opened my developer console.
But I'm not happy with that solution.
I was using google chrome and facing the same "LOADING" developer console issue.
I just log out from GC and then opened in the IE and then the developer console is opened.
immediately, I have opened it in GC it is working fine.
can anybody help me with the proper solution?
Rushikesh Pawar 7Rushikesh Pawar 7
Thanks. It worked for me.
Frederic Lapierre 5