function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Isias FloresIsias Flores 

My Developer Console is not loading

Since I am testing Salesforce, I can´t see my Developer Console.

The first message is "Loading configuration...". 
Then I read "Loading workspace...", and that´s all.
I can´t see nothing else.

My Internet connection is perfect, and I´m using Firefox and Google Chrome.

I don´t understand what´s happening.

Please, help me!

Thank you.
Abhinav GuptaAbhinav Gupta
Usually Chrome goes best with dev console. The only reason I see is network latency, if I am in APAC (India/Asia) zone and trying to hit NA servers, its comparetively slower. Try using ASIDE.IO it usually goes well for me in such situations.
Abhinav GuptaAbhinav Gupta
You can also try clearing your DNS Cache, as explained in my blog :

It in general fixes internet latency and other slowness
Isias FloresIsias Flores
Thank you for answer.

I already cleaned my DNS Cache and nothing happenned. I´m having the same problem.
I also tried using ASIDE.IO but it's too much slower than

This is the text of my Firefox console:

"Loading config..." main.js:1745
uncaught exception: Event preferences:update is not registered.
"(/_ui/common/apex/debug/ApexCSIPage) uncaught exception: Event preferences:update is not registered." main.js:1745
"Loaded config..." main.js:1745
"Steaming API initializing..." main.js:1745
"Querying for trace flags..." main.js:1745
"Session initialized" main.js:1745
"Steaming API connected" main.js:1745
"No trace flag, creating..." main.js:1745
And this is the text of my Chrome console (wich is similar to the Safari console text) :

Loading config...
Loaded config...
Failed to load resource: the server responded with a status of 403 (Forbidden)…%20FROM%20UserPreference%20WHERE%20UserID%20%3D%20%27005o0000000Iz8LAAS%27
(/_ui/common/apex/debug/ApexCSIPage) Uncaught Event preferences:update is not registered.
Uncaught Event preferences:update is not registered. ApexIDECore.js:21
Steaming API initializing...
Querying for trace flags...
Session initialized
Failed to load resource: the server responded with a status of 403 (Forbidden)…00Iz8L%27%20OR%20ScopeId%3Dnull%20OR%20ScopeId%3D%27000000000000000000%27)
Steaming API connected
No trace flag, creating...
Failed to load resource: the server responded with a status of 403 (Forbidden)

¿Does this mean anything?

Thank you.
Daniel NowocinskiDaniel Nowocinski
Solution that worked for me is (IE instruction, i'm sure it's similar for all browsers) : when you see developer console page with "loading workspace..." message, right click on page, go to the properties | certificates | Install Certificate and then complete the certificate installation with wizard, after that reset your developer console.
Anubhooti PaliwalAnubhooti Paliwal
Flushing DNS helped me to overcome this problem.
Simple 3 Seps  to fix this !!

**Open Developer Console => Copy Url from developer Console ==> Paste it in New browser tab
here go to workspace ==> Workspace manager => delete old workspace and create new one
Now try to open developer console**

This worked to me when I was facing chrome and application Unresponsive when I open developer console.

Hope this helps you!!

Please do not forget to mark this thread as SOLVED and answer as the BEST ANSWER if it helps address your issue.
Prudhvi A 15Prudhvi A 15
Hi All, 
for any reason, if you want to reset the Developer Console session. Please find the below steps.

   1: Log in to the workbench > Navigate to Utilities > REST Explorer then select Get radio button
   2: Use below service URI and Select Get Method radio button then execute
                       1. /services/data/v31.0/tooling/query/?q=SELECT+id,+UserId+,name+from+IDEWorkspace+where+UserId+=+'0050U000002nxTJQAY'
                       2. It gives Developer Console Session Id
  3. Select Delete Rest method in REST Explorer then add session id to end of this URI /services/data/v29.0/tooling/sobjects/IDEWorkspace/sessionID then execute
 4. Login to Developer Console, It works as expected

for more details. Please visit the blog for a detailed explanation mentioned below.