function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Vivek Ukidve 7Vivek Ukidve 7 


Hello ,
           I am new to salesforce ,follwed steps describe in Mobile_SDK.pdf ,I stuck at this point ,gives me the following error...............

07-02 12:00:27.020: I/ClientManager:getRestClient(2842): No account of type found
07-02 12:00:27.020: D/AccountManagerService(332): bind attempt failed for Session: expectLaunch true, connected false, stats (0/0/0), lifetime 0.0, addAccount, accountType, requiredFeatures null
07-02 12:00:27.030: W/AccMgrCallback:run(2842): android.accounts.AuthenticatorException: bind failure
07-02 12:00:27.030: W/AccMgrCallback:run(2842):  at android.accounts.AccountManager.convertErrorToException(
07-02 12:00:27.030: W/AccMgrCallback:run(2842):  at android.accounts.AccountManager.access$400(
07-02 12:00:27.030: W/AccMgrCallback:run(2842):  at android.accounts.AccountManager$AmsTask$Response.onError(
07-02 12:00:27.030: W/AccMgrCallback:run(2842):  at android.accounts.IAccountManagerResponse$Stub.onTransact(
07-02 12:00:27.030: W/AccMgrCallback:run(2842):  at android.os.Binder.execTransact(
07-02 12:00:27.030: W/AccMgrCallback:run(2842):  at Method)
07-02 12:00:27.090: I/ActivityManager(332): START {flg=0x10000000} from pid 2842
07-02 12:00:27.150: I/WindowManager(332): SCREENLAYOUT_SIZE (1:small, 2:normal, 3:large, 4:xlarge) 2
07-02 12:00:27.180: I/ActivityManager(332): Displayed +323ms (total +32ms)
07-02 12:00:27.300: I/dun_service(203): received event(DUN_EVENT_USB_UNPLUG) in state(DUN_STATE_USB_UNPLUG)
07-02 12:00:27.310: D/WifiService(332): ACTION_BATTERY_CHANGED pluggedType: 0

...required some guidance ...thank u 

Hi Vivek, 

The issue is most likely that you've used the (generic) com.salesforce.androisdk account type on more than one app—e.g. one of the sample apps and your new app—on your emulator/device. The Mobile SDK doesn't find the account initially for your new app, but then ends up trying to access the account from the previous app, and so you run into bind failures, security/privileges exceptions, etc.

You should be overriding the account type in your application, with a value that's unique to your particular app. In your app's strings.xml:

    <string name="account_type">com.yourpackage.yourapp.auth.account</string>
That should get past the bind failure. The "No account of type" message is expected the first time you log in.

A future version of the Mobile SDK for Android will make this account flow more robust, so hopefully the issue won't come up.

Nazrul AminNazrul Amin
Hi Ashish,

I tried your solution above, and still the same error persists.  Any other ideas?