+ Start a Discussion

Insufficient Privileges Error on 'cancel' button click or doing any Ajax rerender on All vf pages in my app

Suddenly lots of subscribers, to an app I developed, are facing issue of 'Insufficient Privileges' error.

The error comes in at any kind of PostBack action I am doing or an AJAX action like rerender a pageblock. The weirdest of all, it is happening on a button click on which I've no custom APEX code.

Say, I've a page with following button, using a "StandardController" pointing to a customobject, like this:

<apex:commandButton action="{!cancel}" value="Cancel" />

This button should call to StandardController object's cancel method and yet, the current page it is called upon is postbacked, the URL remains the same as before, and all other content of page is gone and this deadly error is shown:

"Insufficient Privileges
You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary."

The strangest thing is, I can reproduce this issue in number of orgs like right now, and the app is like 3 years old, nothing modified in recent months on the app, suddenly it just went dead like this, all of the VF pages are throwing this error on any postback.

Can anyone suggest what could be the reason for this?

I've verified that, even System Administrator is getting same error, Org-Wide Sharing rules are correct, no permissions configured that restrict access, Every user has rights to access to others owned data, and also profiles have modify and view all permissions, but still getting same error.

Best Answer chosen by VarunC
Ok, got some info to this so want to add it here.

Salesforce has identified it to be an issue, they pushed some platform update last night. (didn't know if Salesforce was doing updates over weekdays). So something messed up in te update, and you will be encountering this issue.

Root cause:
The cause of the issue is: If you ahve ANY Package that has Expired, you might face this issue in other package's VF pages.

Workaround suggested by Salesforce:
Uninstall the Expired Package or have the Expired Package Turned Active by the Publisher of the app.