function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
pintoo rajputpintoo rajput 

This record type cannot be deactivated because the following profiles use this record type as default.

Please solve this problem how to deactive profiles from recordtype??
Deepak Kumar ShyoranDeepak Kumar Shyoran
If you want to deactivate that record Type then first you need to remove all the references with that record Type which means go to that profile which using that record type, and then try to deactivate that Record Type.
Virendra ChouhanVirendra Chouhan
Hi Pintoo,

You can't deactive any record type if they are in used.
In the bellow of this Error you seen some profile Name where your Record type is used .

( In my case i use a record type which is created in opportunity )

User-added image

So first remove the usage of record type from profiles.

Click on the profile link and then go to Record Type settings (without clicking on Edit button)
User-added image

Then click on This Edit and remove this Record type and select Master . (Because alteast one record type must be selected)

User-added image

And then Save.


Ajay K DubediAjay K Dubedi
Hi Pintoo, 
 If you want to delete a record type and if its showing that error you mentioned or any dependency, then you have to remove that dependency first and the try to delete it again. Its like You are using that record type in a profile and trying to delete that record type without removing it from the Profile where it is used. So as Virendra Chauhan has suggested, please try to remove the dependency and then try again.

Hope this helps.
Virendra's instructions work fine for profiles with standard/custom record type settings but certain profiles don't have or don't expose these settings, eg
  • Chatter External User
  • Chatter Free User
  • Chatter Moderator User
How to deal with these? Script / code?
Found the answer by Karanraj Sankaranarayanan in Salesforce Success, Problem to delete record type,
Prasad Joshi 44Prasad Joshi 44
Hi Please follow the following steps

1) Click 'Setup'
2)  Drop down the 'Users' ..... you will see the option'  User Management Settings' Click  this option.
3) You will see  2 sections. Enable the all the 3 options in lower sections as 'Enabled'.
4) Go to the perticular object then [i] Click  'Record Type'  select the perticular Record Typre you want to edit and [ii]remove the check box [iv] Click Save.
You will get the same error message, but dont worry.
User-added image
5) Click on the listed profile .It will open below page which is simmiller to permission set page (its not permission set)

User-added image

6) Select the object related to that Record Type. You will get page like mentioned below
User-added image

Change the Record Types and Page Layout Assignments
User-added image

then Click  Edit Properties Button and save it.
7) Go to Page Layout edit option and do same for remaining fields.
8) Once you follow same procedure for the remaining profiles you and assign   Record Types and Page Layout Assignments to --Master--   
9)You can now Uncheck the ACTIVE  Checkbox & you can delete that Record Type.
Prasad Joshi 44Prasad Joshi 44
But from above steps you cant remove Object ReordType in
  • Chatter External User
  • Chatter Free User
  • Chatter Moderator User
  • Custom: Support Profile
  • - App Subscription User
for that use 
https://[your org][Profile ID]&tid=[Object TID]&pn=[Profile name and use "+" to replace blank]
follow steps mentined as per given link (
To set/assign a record type 
to remove a default record type from profile

Goto Settings -> Users -> Profiles ->
                                                         Select respective Profile -> Record Type Settings ->Select respective Object  (Edit the record type) 

There we can add/remove the recors types which is already created as per the need.