function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Bug Report: Internal Oracle Errors "SQLException while executing plsql statement"

My organization is experiencing internal Salesforce/Oracle errors when using certain custom VF pages in our Salesforce Community.  The error messages look like this:
Error Message ($Site.ErrorMessage): Error occurred while loading a Visualforce page.
Error Description ($Site.ErrorDescription): common.apex.runtime.impl.ExecutionException: ORA-20001:
ORA-06512: at "SLEEPY.CAUTHSESSION", line 811
ORA-01403: no data found
ORA-06512: at line 1 
SQLException while executing plsql statement: {?=call cAuthSession.get_session_key_nc(?,?)}(EXCLUDED, false)

We don't have perfect steps to reproduce the issue, but we've identified a couple scenarios which often make this happen.  I've listed the scenarios below.  This is currently affecting at least two users in our production environment and in a sandbox. We opened case #10907381 but it was closed, and we were told to file the bug report here.

For all of these scenarios, it's helpful to keep the Developer Console open so you can access logs.

Scenario 1: Page Opens Normally in ClientConnect Community
0) Start from Health Leads Internal
1) Switch to the Community called "ClientConnect"
2) Go to this VF page:
3) Page opens normally

Scenario 2: Page Crashes in Advocate Management Community
0) Start from Health Leads Internal
1) Switch to the Community called "Advocate Management"
2) Go to this VF page -
3) Crash! if you open up the log in the Developer Console, the error message displayed.

Scenario 3: Page Crashes If You Were Ever In Advocate Management
Now that you've completed scenario 2, go back and try scenario 1 again.  While it worked before, this time it crashes.
James LoghryJames Loghry
It's likely a configuration issue of some sort.  I would look for differences in the ways your communities are configured.  Anything from the Sites pages to the Sites user's profile to your Community Sharing Settings.

In particular though, does your Advocate Management Community have access to the MyDeskReports visualforce page?  You can check this by going to Customize->Communities->Manage Communities and then click on "" under the "Custom Pages" column.
That makes sense.  We'll give this a try and see if it makes a difference, then report back.
@James Loghry,  have tried all your suggestions and so far it's still happening...