+ Start a Discussion
priya burghatepriya burghate 

Error while logging in to web service at: https://login.salesforce.com/services/Soap/u/30.0, error was: Failed to send request to https://login.salesforce.com/services/Soap/u/30.0

Hi all,
Im inserting data from dataloader through command line
ive followed following steps
1.erypt -g test
2.encrypt -e mypass+security token "Path of my key.txt"
3.write process.xml as below

process-confg.xml
<!DOCTYPE beans PUBLIC "-//SPRING//DTD BEAN//EN" "http://www.springframework.org/dtd/spring-beans.dtd">
<beans>
    <bean id="accountInsert"
          class="com.salesforce.dataloader.process.ProcessRunner"
          singleton="false">
        <description> uploads them to salesforce using 'upsert'.</description>
        <property name="name" value="accountMasterProcess"/>
        <property name="configOverrideMap">
            <map>
                <entry key="sfdc.debugMessages" value="true"/>
                <entry key="sfdc.debugMessagesFile" value="C:\Users\a579510\Desktop\dl\samples\status\accountMasterSoapTrace.log"/>
                <entry key="sfdc.endpoint" value="https://login.salesforce.com"/>
                <entry key="sfdc.username" value="priya.burghate@atos.net"/>
                <!-- password below has been encrypted using key file, therefore it will not work without the key setting: process.encryptionKeyFile
                the password is not a valid encrypted value, please generate the real value using encrypt.bat utility -->
                <entry key="sfdc.password" value="f128334f5306b5d53ea345ba07b816f8557994a62dcdc346fdf664bb2c35836c1d13f1fb4a37933f"/>
                <entry key="process.encryptionKeyFile" value="C:\Users\a579510\Desktop\dl\samples\conf\sample.txt"/>
                <entry key="sfdc.timeoutSecs" value="600"/>
                <entry key="sfdc.loadBatchSize" value="200"/>
                <entry key="sfdc.externalIdField" value="Oracle_Id__c"/>
                <entry key="sfdc.entity" value="Account"/>
                <entry key="process.operation" value="upsert"/>
                <entry key="process.mappingFile" value="C:\Users\a579510\Desktop\dl\samples\conf\accountInsertMap.sdl"/>
                <entry key="dataAccess.name" value="C:\Users\a579510\Desktop\dl\samples\data\accountData1.csv"/>
    <entry key="process.outputError" value="C:\Users\a579510\Desktop\dl\samples\status\error.csv"/>
    <entry key="processOutputSuccess" value="C:\Users\a579510\Desktop\dl\samples\status\success.csv"/>
                <entry key="dataAccess.type" value="csvRead"/>
                <entry key="process.initialLastRunDate" value="2005-12-01T00:00:00.000-0800"/>
            </map>
        </property>
    </bean>
</beans>

but gives an error
Error while logging in to web service at: https://login.salesforce.com/services/Soap/u/30.0, error was: Failed to send request to https://login.salesforce.com/services/Soap/u/30.0com.sforce.ws.ConnectionException: Failed to send request to https://login.salesforce.com/services/Soap/u/30.0

pl z add your valuable suggetions......
priya burghatepriya burghate
Thax for reply Raja .But im not using sandbox.
im using login.salesforce.com....
what is going wrong?
plz post if you have any suggetions...
priya burghatepriya burghate
my folder hierarche
conf--key.txt,process-conf.xml and sdl file
data--account.csv
status--success.csv,error.csv and log file

every time when i run it create config.properties and lastrun.properties file
n success123.csv generated
n on cmd getting same error
wht should i do?
priya burghatepriya burghate
now salved this issue by setting 
fdc.proxyUsername=proxyUserName

sfdc.proxyPassword=encrypytesPassword

sfdc.proxyHost=proxyhostName

sfdc.proxyPort=123
Shalini HurleyShalini Hurley
when I use https://test.salesforce.com/services/Soap/u/25.0 for the APi call I get the error
Invalid element in com.sforce.soap.partner.fault.UnexpectedErrorFault - upgradeURL. 
Siva@63Siva@63
Hi Priya,

I am trying to execute command line dataloader from our server, where as there are no proxys setting setuped  in our server.
In process-conf.xml i have included below lines as blank as our server doesn't hold any settings.

<entry key="sfdc.proxyUsername" value="" />
                <entry key="sfdc.proxyPassword" value="" /> 
                <entry key="sfdc.proxyHost" value="" />
                <entry key="sfdc.proxyPort" value="" /> -->

Error while calling web service operation: login, error was
: Failed to send request to https://test.salesforce.com/services/Soap/u/44.0
com.sforce.ws.ConnectionException: Failed to send request to https://test.salesf
orce.com/services/Soap/u/44.0

Caused by: org.apache.http.conn.HttpHostConnectException: Connect to test.salesf
orce.com:443 [test.salesforce.com/85.222.129.39, test.salesforce.com/85.222.128.
167, test.salesforce.com/85.222.129.167] failed: Connection timed out: connect
        at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect
(DefaultHttpClientConnectionOperator.java:158)


The encrypted Key and encrypted Password was correct as i could able to extract the file on my local PC where as when i tried to implement the same in our server, i am getting above error.
As i said at server level nothing proxy was setuped and same was checked with IT team.

Please suggest any inputs how to proceed further.

//Siva