+ Start a Discussion
Ross GoldbergRoss Goldberg 

Permission Sets missing system permissions

When we install a managed package our permission sets are missing the system permissions defined in our DE:
  1. System Permissions hasn't been populated after package was installed.
  2. System Administrator can't edit System Permissions after deployment from managed package

Is this by design or should we be able to deploy system permissions?

Thanks,
Ross
Shashikant SharmaShashikant Sharma
Hi Ross,

I think this post might help you : http://salesforce.stackexchange.com/questions/1325/app-disappears-from-permission-set-included-with-package

Thanks
Ross GoldbergRoss Goldberg
Thanks.  I found this:

You can include permission sets as components in a package, with the following permissions and access settings:

Custom object permissions
External object permissions
Custom field permissions
Custom permissions
Apex class access
Visualforce page access
External data source access

Note

Assigned apps and tab settings are not included in permission set components.

from:

http://www.salesforce.com/us/developer/docs/packagingGuide/Content/packaging_component_behavior.htm

But this doesn't speak to system permissions... I guess they are in the exclusion list because they aren't in the inclusion list? :-)

Shashikant SharmaShashikant Sharma
You could mark this post as solved if your doubt are clear so others could get benifitted from it.
Ross GoldbergRoss Goldberg
Shashikant, it is not yet solved as I do not know if system permissions should be included or not.  The documenation does not specify.  I am hoping for additional clarifiation.

Thanks,
Ross
Shashikant SharmaShashikant Sharma
See this it does say about system permission : http://www.salesforce.com/us/developer/docs/securityImplGuide/Content/perm_sets_overview.htm . 
Ross GoldbergRoss Goldberg
Yes, permission sets include the ability to include system permissions.  But when they are packaged not all attributes of the permission set are included.  Should system permissions be included during packaging?  Is this supported by the platform?

Thanks agian,
Ross
Shashikant SharmaShashikant Sharma
One question here ,

 Is this permission set being added to package first time or it is being updated and going again?

One thing i will say if you have not done that install this app again to a fresh org and see behavior.


Ross GoldbergRoss Goldberg
The permission set is being updated with changes.  The installation is going into an existing org where the previous version of the managed package was first uninstalled.
Shashikant SharmaShashikant Sharma
I think only way to check whether permission set carry system permission is to install the same package on another org and see if the bahavior is same. 
mintotsai@dev.jasminemintotsai@dev.jasmine
Is there any new information on this? My permission set with "View Encrypted Data" System Permission is in a managed packaged. After deploying the package to a production org, the permission set no longer has the "View Encrypted Data" permission set. However, if I deploy the package to a development org, the permission IS set.
John Buck 8John Buck 8
I am trying to get permission to develop Apex triggers.   registered as developer, but it is still not clear to me how i get permission to develop apex code.   still get the "insufficient privilidge error"