function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Seb OrtizSeb Ortiz 


Hi all,

We are getting an URL_NOT_RESET error in REST API when trying to connect to a Production Org with * domain.
We are reproducing the same error when trying to connect with Data Loader, Workbench and Developer Console. It also happens in Developer Sandbox.

The Org has a My Domain set up, if that means anything

Steps to reproduce:
1. Login and get access_token
2. Call any API resource using the same domain returned in instance_url in step 1. i.e.

Please help! it's critical

Seb OrtizSeb Ortiz
Secondly, I'm loging in as Sys Admin so User has API Enabled = TRUE
Seb OrtizSeb Ortiz

Thanks to SF support who gave us the following workaround:

1. Go to Setup > Domain Management > My Domain
2. Edit "My Domain Settings"
3. Fill original domain name and click "checkAvailability" button again. It will delete the checked domain name and restore original domain name.

This also solved the same error on Data Loader, Workbench and Developer Console.

Happy days!