function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Ross GardnerRoss Gardner Studio for Community missing access to "data elements" and "data repeater"

I posted a picture below to show the issue. When I signed up for Studio for Community yesterday I had access to "data elements" and "data repeater", but now I do not.

Things that I have tried:
  • searched through help and training for 2 hours and did not find what I was looking for.
  • I read through the entire Community manual
  • I tried changing permissions
  • I tried changing "guest user settings"

No access to Data Elements
PratikPratik (Salesforce Developers) 
Hi Ross,

Please let me know what Salesforce edition you are using?

You can refer this:

Ross GardnerRoss Gardner
I am using Enterprise Edition. 

I did refer to that help article, however I cannot even complete Step 1 because I don't have any Data Elements in the Page Elements pane. If you zoom in on the image that I attached below you can see all of my Page Elements on the left side of the page. 

Here is Step 1: Drag a Data Element from the Page Elements pane onto the data repeater. Alternatively, if the page has a page data connection, drag the Data Element page element directly onto the page canvas.

Here is a screenshot that shows my Page Elements pane missing Data Elements: Studio for Community missing Data Elements in the Page Elements pane

Thank you for your response, Pratik.
Jonas MyhreJonas Myhre
Did you figure this out, Ross? Having tested a bit, it seems the issue is having any page templates there (which sucks to be honest.. ) . See images below, its the same home page, but its with and without the page template on the page:

User-added image         User-added image

Pairin MasonPairin Mason


I have the similar issue. Page Elements of Forms, Data, Navigation, etc. are missing for the Site page with/without page template I created.

Only Content, Layout, Widgets are available. 

User-added image


Any idea?

Thank you,



Alastair Dinning (dev)Alastair Dinning (dev)
I hit the same issue a couple of days ago, and this is the KnowledgeBase article I was pointed to by Partner Support.

"If you are planning to use Data and Form components from (in community sites), then do not use templates to create a community."

Its been some while since you posted this, so did you find a workaround?

Camila Heitz 4Camila Heitz 4
I have the same issue, could anyone work this out?