+ Start a Discussion
Will Jones 18Will Jones 18 

Apex Test not running in Sandbox. All test stay Queued

For the past two days I've noticed that none of my apex class test are working in my sandbox. Whether I run all test or run them individually they do not work. No pass, no fail, just stays queued. I've tried clearing my test data, compiling the classes and everything but still no change. Anyone seen this and how did you solve the issue? My test work fine in my production instance.
Best Answer chosen by Will Jones 18
i suspect youre going to need to file a case about this.

All Answers

i suspect youre going to need to file a case about this.
This was selected as the best answer
Robert ZentgrafRobert Zentgraf

Hi Will Jones 18,

I have the same issue with my sandbox. Do you find a solution?


(mindforce: http://www.mind-force.de)

Will Jones 18Will Jones 18
Hey I created a ticket with SF and apparently this is a known issue in some spring 15 sandbox instances. They told me to subscribe to the thread below and someone will get back to me. Looks like they will be rolling out a fix soon. Not the best answer but an answer.

Thibault WeberThibault Weber

Until this is resolved, you can use Eclipse IDE to run your tests. This is the only way I've found to execute my tests now.
Jean DuqueJean Duque
We are also affected by this issue, but as @thibault said, I used the Eclipse IDE to run and deploy in production, good luck with that until salesforce solves the problem.