function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Robert ZentgrafRobert Zentgraf 

Issue with process builder after approval process


I hope, that this is the right place for my question.
I tried a few features with the new process builder and I'm not sure about this "issue":
  1. Approval process is working and at the end the status field will be updated to the next value.
  2. This new value should start the process builder-WF. But this is not happened.
=>But, if I change the value manually (without approval process), then the process builder-WF fires.

Can someone explain me this behaviour?

it sounds like an approval process is not firing the event to kick off the process. 
I just polled my collection of process builder experts and none of them have ever tired to fire off a process with an approval process. Becaues of this I'm not sure if it's a bug or expected behavior. 

In the mean time, you can acomplish this by using a WFR to fire off the process whenever the aproved record has hte appropriate status.
Douglas Midgley 7Douglas Midgley 7
Hey Rob,
Did you find a resolution?
I'm having exactly the same issue. Even when I build it into the same process and have as recurring it still will not fire the next approriate action based on the field change.
Steffan HoekeSteffan Hoeke
Came across this question while investigating a similar issue i was having.
In our case, the field update of the Status field did not have "Re-evaluate Worfklow Rules after Field Change" checked; after checking it the process started firing as expected.
Neel Kamal 6Neel Kamal 6
Steffan Hoeke answer should marked as best answer
Scott Walker 53Scott Walker 53
Thanks Steffan.   Had the same issue and this worked for me as well.