function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Trailhead / Data Security / Controlling access to the organization – Error

Hi everyone, I cannot validate the module Controlling access to the organization because an error message appears: “The user's profile was not set to System Administrator”.
The thing is that the user profile I’ve created was well set to System administrator. I’ve been trying to do it again but still not. Has someone had the same issue? What Can I do?
Jennifer W. LeeJennifer W. Lee
Can you provide a screenshot of the guestadmin user you created?
Thanks for your help.
As you'll see, there is "guestadmin" in the username, Administrator system in profile and unactive...
Sorry for the french words...
User-added image
Finally I found! Actually my contact was good, but during my attempt, I had created other contacts and one of them had "guestadmin" in the e-mail I had created, so the machine couldn't verified because there were two contacts and not one.
Hello eldudi actually i'm facing the same problem i have the same error message “The user's profile was not set to System Administrator” and despite your solution i've not yet fixed the problem. Perhaps i don't get your solution well. Please could you explain me how you fixed it. I precise that i'm following the Salesforce training. Thank you in advance   
André MirandaAndré Miranda
Hi, I had the same problem and i solved changing the idiom from my profile for english.
Samantha WanningerSamantha Wanninger
thx @André Miranda that's also my solution!

Change your Language to English and check again.. than everything works fine :)
Sergii KovalSergii Koval
Im trying to create a user, but I dont have an option in License "Salesforce" and in Profile I cannot choose "Administrator Profile". Guys, could you help me?
Kim VarniKim Varni
Sergil - did you ever figure it out? I dont have the option for an Administrator profile as well. 
Kim VarniKim Varni
Now I understand. You need to inactivate ANY other user you have created in the developer instance. I did not have another system admin but i did create another test account. 
Deep GrewalDeep Grewal
I had a similar issue, multiple accounts with Guestadmin in the username/email address. I tried freezing the other account, didn't work.

Here's what you need to do. Edit each of the user records, making sure they are both inactive. Change them each to Salesforce and Profile: System Administrator. Refresh and Check Challenge :)