function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
riz wanriz wan 

Why threre are no log entries in developer console?

I an a newbie to salesforce, and was following workbook on apex classes.
This is what i did:
Debug-> Open Exceture Anonymous Window.

Unchecked "open log". Execute

Alas, i couldnt see any log entries, while the workbook says that log entries will appear.
Do i need to make changes somewhere? or
Am i doing it wrong way?
Sai Ram ASai Ram A
Hi Rizwan

I think you are on the Right Track. Try executing by checking "Open log",
use sample code: 
String st = 'Say Hello World';
System.debug('Print st: '+st);
User-added image

Thank you
BLearn - Sai
riz wanriz wan
Still the same :(
A blank log even after doing what you asked for.
User-added image
pranav prashantpranav prashant
I'm having the same issue. Did you resolve it?
riz wanriz wan
Mudasir WaniMudasir Wani
Debug logs are based on user.
Sometimes developer console will upset you.
What you can do is follow the following points.

GoTo Setup.
Find Debug Logs Under Logs section OR Debug Logs under Monitoring in Old Orgs
After you click on debug logs you will be redirected to another page.
You will see a Add New User button click and add you user and save.
You are done, Now run your code and reset the logs --Find reset on left of your added user

User-added image

For More details please refer

Please mark this as solution if this solves your problem, So that if anyone has this issue this can help.
riz wanriz wan
That saves log in my account, but still i am unable to see logs in Developer Console.
How to fix that (i already have tried running developer console on firefox/chrome)
Abilash Kosigi 8Abilash Kosigi 8
Which browser you are using. I faced lot of issues with Internet explorer. Logs wont get refreshed every time you run apex. Use Google chrome which would serve you the best.
Cray KaoCray Kao
Have the same issue, too.

Chrome Version 41.0.2272.118
Aamir MemonAamir Memon
Try to go to Setup > debug level and make sure to set the Apex Code to Finest