function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Salesforce in GIT

Hi There,

Im a newbie using GIT and just tried to use the GIT as our version control system. I went through following dream force tutorial by John Stevenson. (

I was able to create the GIT account and tried to unpack the Package that i have created on one of my sandboxes. Steps I followed was,
1. Add Force exe (from CLI for Windows) file in to the GITHub -> myrepository folder
2. After Force Login, I Tried to execute the following command to unpack the Package
(force fetch -t=package -n=packagename -unpack)
3. Nothing happened and I kept getting the message 'Gonna do this again'

Please let me know if something wrong with this steps? Is this the correct way to do version controling even for Apex classes, triggers as well?
Also can someone suggest more tutorials/blogs that I can refer to? 
Mark HartnadyMark Hartnady
Nothing is wrong. If you let step (3) run for a while longer, you will find that your meta-data will download. You should see the "Gonna do this agin" message repeated up to 20 times. The process eventually terminates and your data downloads. Patience!