function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Robbie DellRobbie Dell 

Rich text area on Salesforce1 has different behavior compared to mobile browser while editing a record

Hi All,

Rich text area on salesforce1 doesn't function the same way as in mobile browser (chrome mobile view). Need help on this. Please refer to the image below. 

User-added image


Robbie DellRobbie Dell
Also the value of the field doesn't show when editing on salesforce1 app (left), unlike when using a mobile browser (right) were the value is there initially.
Leslie  KismartoniLeslie Kismartoni
Just tried this on iPhone6 device and see that it works pretty much like on mobile Chrome. Finding an android device to test with now...
Leslie  KismartoniLeslie Kismartoni
Ok - def. seeing that the rich text field is not behaving the same on an Android device... I tried updating to Version 7.1.2 (most recent) and it is still blank.

Workaround: Use IOS if possible in the short term and file a bug?
Gaurav KheterpalGaurav Kheterpal
Can you confirm what specific OS/ Android version are you seeng this on?  This was supposedly fixed in v4.4.3 and above.
Brian KavanaughBrian Kavanaugh
I'm on 4.4.4 on a Motorola Droid Turbo, and I have the same issue. Worse, since it doesn't populate the field with the stored value, saving blanks the field.