+ Start a Discussion

destructiveChanges bad file

I'm trying to deploy a destructiveChanges.xml file. I've updated the file name to accomodate the new pre/post function (http://www.salesforce.com/us/developer/docs/daas/Content/daas_destructive_changes.htm): destructiveChangesPre.xml.

Here are the contents:
<?xml version="1.0" encoding="UTF-8"?>
<Package xmlns="http://soap.sforce.com/2006/04/metadata">
The server was just updated to the Summer 15 release (API v 34.0).

I have a package.xml file as described:
<?xml version="1.0" encoding="UTF-8"?>
<Package xmlns="http://soap.sforce.com/2006/04/metadata">

I run the following target via ANT to use the Metadata API:
<target name="vDeployDev1">
      <sf:deploy username="${sf.undev1}" password="${sf.pwdev1}" serverurl="${sf.urldev1}" deployRoot="src" rollbackOnError="true" ignoreWarnings="true" checkOnly="true" purgeOnDelete="true"/>

I authenticate but the deployment fails:
C:\Users\gazaino\Projects\Release_15-5-1>ant vDeployDev1
Buildfile: C:\Users\gazaino\Projects\Release_15-5-1\build.xml

[sf:deploy] Request for a deploy submitted successfully.
[sf:deploy] Request ID for the current deploy task: 0AfM0000008hUi1KAE
[sf:deploy] Waiting for server to finish processing the request...
[sf:deploy] Request Status: InProgress
[sf:deploy] Request Status: Failed

*********** DEPLOYMENT FAILED ***********
Request ID: 0AfM0000008hUi1KAE

All Component Failures:
1.  package.xml -- Error: Bad file:Element {http://soap.sforce.com/2006/04/metad
ata}names invalid at this location

*********** DEPLOYMENT FAILED ***********

If I remove the destructiveChangesPre.xml file from my src folder, it deploys successfully - so I'm assuming the error is in the destructiveChangesPre.xml file.

Is anyone else running into this issue? Is it a bug in the new release? Am I missing something in my deployment files? I copied everything from prior releases where the deployment worked, so I'm assuming it's a bug. Any help would be greatly appreciated.
kevin lamkevin lam
Are you sure CustomApplicationConsole is a valid metadata type?
Hey Kevin, thanks for the reply.

Unfortunately for solving this, it is a valid type (https://www.salesforce.com/us/developer/docs/api_meta/Content/meta_customapplicationcomponent.htm). I believe I attempted to remove the types to simplify the package and still received the same error. I will double check that in the morning though.
Kevin - thanks again. That didn't answer it, but definitely made me go back and check the file itself. The problem was I included an 's' on the name element:
as opposed to:
The error message makes a lot more sense now too.