function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Ravi NarayananRavi Narayanan 

Index.html not found - Cordova

Hello all,

I followed the steps for creating a hybrid remote mobile app using foredroid and cordova. But once i build and run the emulator, i am getting error index.html not found.can someone pl help me with this?

Ravi Narayanan
Eric Kendi ShiraishiEric Kendi Shiraishi

I ran into the same error and could make it work.

Even using the forcedroid, I forced a Salesforce pluggin to be added into the project by running the command "cordova pluggin add"
ps: You must have the git commands enable, as cordova tries to clone the github project.

Eric Shiraishi.
Ravi NarayananRavi Narayanan
Thanks for your reply. i am trying to add the plugin. but its been almost 20 mins and still nodejs is showing me message"fetching plugin via gitClone".  is this normal? how long it took for u to add plugin?
Ravi NarayananRavi Narayanan

Thanks bro. i did that and now i am getting a different error when i try to build a cordova project :(
D:\myProjects\testingapp>cordova build android
Running command: D:\myProjects\testingapp\platforms\android\cordova\build.bat
JAVA_HOME=C:\Program Files\java\jdk1.8.0_45
Running: D:\myProjects\testingapp\platforms\android\gradlew cdvBuildDebug -b D:\
myProjects\testingapp\platforms\android\build.gradle -Dorg.gradle.daemon=true

FAILURE: Build failed with an exception.

* Where:
Settings file 'D:\myProjects\testingapp\platforms\android\settings.gradle' line:

* What went wrong:
A problem occurred evaluating settings 'android'.
> A path must be specified!

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug
option to get more log output.


Total time: 9.08 secs

                    throw e;
Error code 1 for command: cmd with args: /s /c "D:\myProjects\testingapp\platfor
ms\android\gradlew cdvBuildDebug -b D:\myProjects\testingapp\platforms\android\b
uild.gradle -Dorg.gradle.daemon=true"
ERROR building one of the platforms: Error: D:\myProjects\testingapp\platforms\a
ndroid\cordova\build.bat: Command failed with exit code 1
You may not have the required environment or OS to build this project
Error: D:\myProjects\testingapp\platforms\android\cordova\build.bat: Command fai
led with exit code 1
    at ChildProcess.whenDone (C:\Users\gssranar\AppData\Roaming\npm\node_modules
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)