function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
fatys chfatys ch 

Mapping problem with file column header (file CSV) in data loader

this is my first post, I am a beginner on apex data loader and I try to do an insert into salesforce.
At the map creation step between columns of my CSV file and fields salesforce, I have a problem, the columns of my CSV file are grouped in one field and therefore it is impossible for me to do the mapping.

Here's a screenshot of what I have.
User-added image

someone can help me?
thank you in advance.
Best Answer chosen by fatys ch
fatys chfatys ch
I found the solution, When you save the file in CSV format make sure that you are in English

All Answers

I think there is some issue with your csv. Try to create a new excel and save it by selecting "CSV (Comma delimited) (*.csv)" extension type from extension drop down.
fatys chfatys ch
That's what I did and I started the same process several times.
It's a shame that I can not attach my CSV file.
fatys chfatys ch
I found the solution, When you save the file in CSV format make sure that you are in English
This was selected as the best answer
Abdeslam Houari 19Abdeslam Houari 19
What do you mean by 
'make sure that you are in English' ??
How did you solved this? I Get the same problem. Turn my Mac in English instead of French but it doesn't solve anything.
OK. You need not only to turn langage in English, but turn all numbers format into Americain so that decimal are not delimited by comma anymore. Otherwise the CSV columns are not delimited by comma (virgule in French) but semi column (point virgule) and salesforce data loader does not understand it. 
After modifying your Mac/PC to get standard American setup, re-export a file from the Data loader. It will be in the correct CSV format for Salesforce, and you can add new row and columns and import it back.
Fabio Marinuzzi 1Fabio Marinuzzi 1
I had the same problem and solved it too by changing the language of the computer to English.
Ryan Dube 2Ryan Dube 2
I am using a mac and have tried all of the above to no avail. can anyone assist me? the format keeps reverting and all my data is showing on 1 line when mapping
Martha VMartha V
I am using a mac also and checked the settings already it is set to English(American). And has always been set that way. But the dataloader wont separate the columns, even though I have tried commas (,) and semicollons (;) as separating values. Any other suggestions?
Martha VMartha V
Never mind, I figured it out. Go to Settings on the Dataloader and click on Allow commas as delimiter values (or something like that). For some reason it was unchecked, even though I have used it before. The only one that was checked was the Tab as delimiter value.
Guilherme TavaresGuilherme Tavares
Just drag your CSV file into a notepad, and replace all semicolons with commas. When you select it again in dataloader it will be as expected.