function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

URGENT - Unable to Access Page

I'm unable to open logs in the developer console. Every time I try to open a log, I receive the following error message:

Unable to Access Page
You are missing information needed by the page you have attempted to access. If you believe this is an error, please refresh your screen. If the error persists, please report it to our Customer Support team and provide the URL of the page you were requesting as well as any other related information. 

Error message screenshot

This issue is similar to this forum post (, but I have attempted its solution and receive the same results.

Logs aren't showing in the "Logs" tab.
Double-clicking test logs from the "tests" tab produces the above error message.
The issue seems to be coming from the "Monitored Users" feature.

If I add myself to the list of monitored users (Setup > Monitor > Logs > Debug Logs > Monitored Users), the tests will run, but it only allows me to run 20 log requests and I am automatically removed.

This is not normal behavior, as a logged-in user should be able to run tests with developer console open and view the results (as per this conversation (

Anyone have ideas on how to get the standard behavior back?

SonamSonam (Salesforce Developers) 
Can you please try the following steps in your develper console and see if this helps:

1) Open Developer Console. 
2) Click the panel "Query Editor" Tab at the bottom of the screen 
3) Write the following Query in Query Editor. 
SELECT Id, NumLinesUncovered FROM ApexCodeCoverageAggregate 
4) Check the checkbox "Use Tooling API" at the bottom of the screen. 
5) Click "Execute". 
6) Select all rows and delete them from "Query Results". 
7) Make sure there are no records of ApexCodeCoverageAggregate 
8) Delete the old test execution histories 
9) Perform "Test Class"

I followed the instructions and for step 8, I used the "Test > Clear Test Data" to remove old test execution history, but I am still receiving the same error.
Sonia Cook-BroenSonia Cook-Broen
I am also having simialar behavior, never happened until today.... the other thing that has been strange lately is the logging in the dev. console. I have to reset the logging levels everytime I login otherwise I don't see any logs at all. Very odd, just started happening in the past month.
SonamSonam (Salesforce Developers) 
Hi, Could you please check the following setting in your ORG setup:
Setup > Develop> Apex test Execution 
Click on the Option button and you will see three checkboxes
Uncheck the first checkbox i.e. Store Only Aggregated Code Coverage if checked and retry running tests.
Sonia Cook-BroenSonia Cook-Broen
Hello Sonam, I have that setting turned off as you suggest but it does not fix the issue. What I have found as a workaround (not ideal) is to update the log settings in the developer console under Debug > Change Log Levels each day. This way I am able to view logs in the console for the VF pages I am developing and testing. This behavior started about a month ago, corrolating with the latest release into the Sandboxes. 
Sonam, this option was already unchecked for me, and I attempted the solution suggested by Sonia, but neither resolves my issue.
Big EarsBig Ears
This problem is affecting us, too. It's frustrating as it's another time I've tried to use the Developer Console and been thwarted....