+ Start a Discussion
Jason Rieckewald-SchmidtJason Rieckewald-Schmidt 

Can't create new case in Community Designer Template

Cannot create case in Community with Napoli designer template
Description We are testing the Community and when we change to the designer template and choose "Contact Support" we get the following error:

"Either this publisher does not exists or you don't have access to it: NewCase"
It is only a problem in the designer templates.

Please let me know how to resolve this. We are using case record types, but are not using "master" as a profile for the record type
SonamSonam (Salesforce Developers) 
I searched for this error to see if I can recreate it but couldn't find anything similar.

Ideally Napili designer template doesn't require any setup as such, however, as you have mentioned your setup has case record types - the users you have created for this community - do they have access to create cases?
Jason Rieckewald-SchmidtJason Rieckewald-Schmidt
it seems like a bug with the global actions. I researched it and salesforce support couldn't resolve the issue
Franziska Lohmann 11Franziska Lohmann 11
I have the same error message with the Kokua Template although I have system administrator permissions. This error only appears in our sandbox, not in the org or in another dev org. 
Franziska Lohmann 11Franziska Lohmann 11
I have solved it. The problem for my part was, that I didn't assign the specific record type on my object settings (case) in the profile. Maybe this could help you, too.
Steven BennettSteven Bennett
See this article: https://help.salesforce.com/apex/HTViewSolution?id=000212359&language=en_US

Look for a Global Action  ( Setup | Global Actions | Actions ) called New Case.

Make sure the record type is set to the specific case type you want. That got the support button working for me.

THANK YOU @STEVEN BENNETT.  That was the fix for me.
Marta GianiMarta Giani
@Steven Bennett you're my hero for today, worked for me too. Thanks a lot!!
Jenna Zelenetz 28Jenna Zelenetz 28
Same here! Now I just have to undo the object-specific actions and web-to-case settings I enabled in desperation. Why is this not in the main implementation documentation?
Raj Kommera 4Raj Kommera 4
Did you override new case button with Visualforce page?
Steve Bennett you are a champion
Christ Valentin 22Christ Valentin 22
It was the answer that kept on healing Admins, Steve. Just help me. Thanks!
Michael Kearney 2Michael Kearney 2
Steven Bennett, thank you! Three years later and your answer still keeps giving!!
Raquel Esteller BerbelRaquel Esteller Berbel
Steven Bennet, you're the one!!! :) Seven years later and your answer still keeps giving!!! :)