function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion

Trigger not firing in production

I have trigger that is not getting fired in production. I create two developer sandboxes trigger works in one not in other.
I tested the trigger updates in Full sandbox before deploying it is still working. 

Here is the simple trigger. When i update the case I do not see the my debug print in logs
trigger CaseTriggers on Case (before update, after update) {

     if(Trigger.isAfter && Trigger.isUpdate){  system.debug('insde Case Trigger');
      //CaseTriggersCls.Case2AccountUpdate (;

How to debug production trigger not firing?
try setting a debug log and update a exisitng case record .
Amit Chaudhary 8Amit Chaudhary 8
Hi SF Dummy,

Your trigger took good. Try to follow below Step:-
STEP 1:- Check trigger is Active or not
STEP 2:- Add your user in debug log
STEP 3:- Update case record
STEP 4:- Check log

Please let us know if this will help you
Yes, I tried all these steps. I have been writting triggers (more then 200) so far. not see this behavior. Cannot contact Support because I not have Premier support.
The debug statement gets printed in Full sandbox not in production. I also tried redeploying the code still not working
I am running testing classes, Debug logs with test class is working in full sandbox not in production

After updating the case, I do not see the debug statement printed in production. I created another developer sandbox yesterday same behavior. Trigger not firing. I have older sandbox trigger works and I see debug statement in logs for older sandbox