+ Start a Discussion
Kelvin CheungKelvin Cheung 

Insufficient Privileges error installing recent versions of our managed package

With our managed package, we are unable to install the package past a certain version as a fresh install onto customer instances.  We receive an "Insufficient Privileges" error when doing so, even if the user performing installation is a Sys Admin.  This happens both with installing directly from a package install URL or from AppExchange and happens in both Sandboxes and Production instances.  Here's an example of the error while trying to install on a developer instance:
 
Y​our request to install package "[package version name here]" was unsuccessful. None of the data or setup information in your salesforce.com organization was affected.
If your install continues to fail, contact Salesforce CRM Support through your normal channels and provide the following information.
Organization: Org Name (org Id)
User: User Name (user Id)
Package: Package Name (package Id)
Problem:
1.  Insufficient Privileges
You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary.

 
Previous versions of the package do not have this problem.  Right now, we are working around this issue by installing an earlier version and then upgrading to new versions (either via push upgrade or providing a link to the newer version).  The upgrade does not run into the same Insufficient Privileges error.

Any help is appreciated.  Thanks!
SonamSonam (Salesforce Developers) 
Could you please give the access URL to the package so I can check this at my end, also mention your ORG ID.
Kelvin CheungKelvin Cheung
URL of newest package version: https://login.salesforce.com/packaging/installPackage.apexp?p0=04tE0000000R2pg
Org Id for dev org: 00DE0000000aexKMAQ

Thanks!
Kelvin CheungKelvin Cheung
We got a clarification from Salesforce Technical Support saying that the specific Insufficient Privileges error was:
"Access to entity 'Note' denied: Entity is not api accessible"
 
That should be helpful, except we don't actually know what this means.  I've seen some posts that say you may get that error when you are using a classname mistakenly as a variable name, e.g. note.Body = 'Hello World' when there is no Note variable, but there's nothing like this in our code.
SonamSonam (Salesforce Developers) 
Hi Kelvin,

I've tried installing this app on multiple apps and am getting the same error, I've gone through the case and am following up with the Tier3 to see if we can get any specific area where Note entity is being used.