function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Becky ChaffeeBecky Chaffee 

Developers Trailhead Challenge in Data Security of Controlling Access Fields

Challenge of Data Security, Controlling Access to Fields in the Developers Trailhead. I spent well over 2 hours on this exercise. It tells me at this time that the "The 'Account Rating' permission set did not have the appropriate field-level security for the Account object."

By now I have tred every combination of check marks and unchecks, and my work place is chaos. Can someone help me with this seemingly simple task?  

Amit Chaudhary 8Amit Chaudhary 8
Please follow below Steps:-

STEP 1:- Please create Permission set with "Account Rating" name.

User-added image

STEP 2:- Provide the Read and Edit access on Account Object

User-added image

STEP 3:- Modify the Field Permissions of rating like below

User-added image

Please mark this as solution if this will help you. So that if some one has same issue this post can help

Amit Chaudhary 
Becky ChaffeeBecky Chaffee
None of the photos showed up. But I got it to work - However, don't understand it. Shouldn't the Field permissions be left out, and just added to the profile of the Account Manager? Thanks so much, Becky
Ksenia LawrenceKsenia Lawrence

Hi Becky, 

"None of the photos showed up. But I got it to work - However, don't understand it. Shouldn't the Field permissions be left out, and just added to the profile of the Account Manager? Thanks so much, Becky"

That's what I thought at first and I got stuck on this question myself. But you have to think of profiles giving basic access and then using permission sets as granting MORE access, hence you add read/edit permission on rating field and assign that permission to Account Manager. (you keep Marketing Cooridnator with his basic profile that DOESN'T have read/edit permissions on rating). 

Hope this helps you a little bit. Just think of permissons sets as ADDING access to fields. 


Francis Alberto Vargas CruzFrancis Alberto Vargas Cruz
Hi, I'm also stuck in this challange but I have a different issue:
The 'Basic Account User' profile did not have the appropriate object and field-level security for the Account object.

I have create and recreate the profile like dozen of times, but the same warning keeps showing up. Can somebody tell me what I'm doing wrong? Thanks in advance.
Ksenia LawrenceKsenia Lawrence
Go to Setup -> Profiles -> Click on your Basic Account User profile. 
Chose the Object (Accounts) to check the settings for Basic Account User for Accounts object. Do you have Read object permission on it? (or have you got more than just Read?) also under field permissions, check what Basic Account User can read.. can he read Rating? or is it unticked? Remember that Basic Account User has to have as little permissions as possible as later on you ADD on those permissions to open up. 
Hope this will help you.
Francis Alberto Vargas CruzFrancis Alberto Vargas Cruz
I did help! Thank you very much Mrs. Lawrence. I was getting frustrated by thin challange.
Amit Chaudhary 8Amit Chaudhary 8
Hi Francis Alberto Vargas Cruz,

In this challange you need to create on profile 'Basic Account User' and and that profile should have read access on account object like below

User-added image

I hope that will help you. Same i used to complete my challange. Please let us know if this will help you.

Amit Chaudhary

Francis Alberto Vargas CruzFrancis Alberto Vargas Cruz
Thanks Mrs. Chaudhary. My problem was that I wasn´t uncheking the rating permissions in the profile configuration. 
Bhavesh SharmaBhavesh Sharma

Hi , 

Is there a workaround to this Rating Field as in the Setup page when we go to the Customize> Account > Fields and set the Field - Level Security to Read only , the same name does not come up in the Profile Object permissions settings page.

User-added image
Is this creating problems ?

Nerd sfdcNerd sfdc
I followed what Amit and Lawrence said. I am still getting an error. Stuck here,
Nerd sfdcNerd sfdc
OH I got it after spending half an hour. I cloned earlier Read Only user profile that's why. We need to take standard user profile and perform all this.
Parth Joshi 24Parth Joshi 24
Hi all, 

I solved this, after done all this. 
1) Just Go to the Account Fields > Rating Fields > Set Field-Level Security > Disable visible and Read Only for all.
2) now check visible and Read only for "Basic Account User" Profile & Save. as shown in below Image.
User-added image

and check for Challenge. 
Hope this will work for all.

Thanks and Regards,
Parth Joshi
Andrew Day 5Andrew Day 5
Parth's Answer is correct however it is Account> Rating Field > Set on so forth for those confused.
Kat Noble MooreKat Noble Moore
Thank you, Parth! That was a huge help.
fred flores 20fred flores 20
The fix noted by Parth Joshi was not correct. The instructions indicate the Profile name should be "Account" not Basic Account user. I would totally agree this lesson needs help. Does not read well. The instruction step by step confusing. I will give Parth thumbs up. Given the instructions he provided did help to get me to pass the lesson just as long as I named the profile "Account". I agree the update if changed to "Basic Account user" makes alot more sense for the name of the Profile instead of "Account".

Appreciate time and effort on this lesson for fixes.
Fred Flores 
Aman PathakAman Pathak
I am also a newbie , I was facing the same issue.
Later I noticed , that I was doing it in Salesforce classic and checking it. 

then I switched to Lightning and found there is no permission set named "rating"  .
So , the problem was only due to the fact that the trail challenges are meant only for the Lightning experience and I was doing it on classic.

Hope this will help someone.