+ Start a Discussion
Pierre-Emmanuel GrosPierre-Emmanuel Gros 

Error in Setting up Lightning Connect trailhead challenge

When doing the challenge in the "Setting up Lightning Connect" step of the Lightning Connect trailhead (https://developer.salesforce.com/trailhead/lightning_connect/lightning_connect_setup), I get a persisting issue with the "Phone Plan" external object (everything is OK with the "Phone" object).

Displayed message is : 
External Object Error
We encountered an error while querying the external data. Contact your administrator about this error. Error received: For input string: "99.99" 

This message appears as soon as I try to add the "cost" field in the default "all" tab list view and systematically on the object detail view (whatever the set of actually displayed fields) for the only ""monthly" record.

When checking the challenge on the trailhead page, no isue is raised band I got a "completed" challenge (but the issue is still there).

Any clue ?  Where can we find logs for "lightning connect" issues ?


Pierre-Emmanuel GrosPierre-Emmanuel Gros
For information, I have French locale setup for my user 
Pierre-Emmanuel GrosPierre-Emmanuel Gros
Setting to US locale did not change anything
Pierre-Emmanuel GrosPierre-Emmanuel Gros
I completed step #3 (Integrating External Data) and tried using the Salesforce 1 Mobile UI. This does not work, as no line is fetched when accessing the "Phone" or "Phone Plan" tabs.
Having the same issue here. The "External Orders" application worked fine, but when I cleaned it up and tried to connect with the Mobile Phones data source, this is the exact error I received.
Pierre-Emmanuel GrosPierre-Emmanuel Gros
Apparently, there is an issue with the OData service for the "Phone Plan" object. When a query is made specifying "cost" as a returned field, it returns as 99.99 which is not compatible with the object definition.
Ralf Hamester (DE-Account)Ralf Hamester (DE-Account)
@Pierre-Emmanuel Gros ...and what would be the solution to this issue?
Pierre-Emmanuel GrosPierre-Emmanuel Gros
No news since then... Problem lies on Heroku service side.
Rajkumar RRajkumar R
Did you change the Object name to "Phone" but not "phones" and the resulting API name has to be "Phone__x".. ?
Bill Powell - CSS IncBill Powell - CSS Inc
I noticed that the table name cannot be changed, it must remain "phones" and is case sensitive. Ensure the API name is "Phone_ _x" and the table name is "phones" and will work fine. I had to re-do that challenge today trying to earn badges on a new account and had to fiddle with it.