function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Margo Schwartz-NewtonMargo Schwartz-Newton 

I wasn't able to connect to my dev org from the challenge page. I got a message saying my session had timed out, regardless of whether or not I was logged in, though not through the trailhead challenge. Are points earned only if connected via challenge?

If you refresh the page you're on (usually with the F5 key) immediately before you select the link to connect to your developer environment you should be able to connect successfully then.

While you can have several developer orgs, to collect your badges and achievements all in one place you should initiate each challenge from the same / Trailhead account.

So first log on from your preferred account and launch all challenges from there.

When you launch a challenge it doesn't matter what dev org you link to in order to complete a challenge.

Points are applied to the / Trailhead account you're logged into at the time when doing a challenge. If you're unsure how this works complete a module that has a Q&A type challenge ( i.e. Doesn't need you to link to a separate developer org and you'll see the challenge points awarded to your account. )

Someone else here may be able to provide a less adhoc solution to the page refresh issue.

One other thing you might notice is sometimes when you initially logon with your preferred account for storing the badges and achievements they may not be initially up to date - It does get updated after a few minutes, sometimes only after you go into a module.
Parker EdelmannParker Edelmann
I was trying to do a project that I had started a while ago, but I can't connect to my org. It is a Developer Edition and runs on the na31 instance. I have tried earlier last week for a challenge, but I got the same error. It doesn't matter if I can see my org on the screen or not, it says my session is invalid immediately after I log in. I followed you're advice to refresh the page first but it didn't help. It knows that the org ID of the org I'm connected to, but it won't stay connected. When I click Launch Developer Edition, even then I'm requested to log in again. Can I have any help with this, becaue it''s been going on for several days and has left me perplexed.