function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Katherine BootheKatherine Boothe 

Custom Lightning Components Not Available to Add in Lightning App Builder

I installed both the Opp Alert Coponent and the ContactsToday Component from the Trailhead Module "Working with Custom Lightning Components". However, they are not available to add as components in the Lightning App Builder. I've tried uninstalling an reinstalling, with no luck. The "Custom Components" section in Lightning App Builder shows 0.

Any help would be appreciated - I've had nothing but technical difficulties with this module and I want to earn that darn badge already!
Best Answer chosen by Katherine Boothe
William TranWilliam Tran
Katherine, make ensure to enable it for Salesforce1.

Setup/build/develop/lightning components 
check the Enable Lightning Components in Salesforce1 (BETA) checkbox.
And try going into your Lightning App Builder again.


All Answers

Naomi HarmonNaomi Harmon
I have the same issue. I installed the ContactsToday Component, and no custom components showed under the Lightning App Builder. I then made sure I enabled Lightning Components in Salesforce1, but when I did that, now any time I try to edit my existing Lightning App or build a new one, I get a 'Server not found' error message (url = I want to earn this badge already too! :)
William TranWilliam Tran
Katherine, make ensure to enable it for Salesforce1.

Setup/build/develop/lightning components 
check the Enable Lightning Components in Salesforce1 (BETA) checkbox.
And try going into your Lightning App Builder again.

This was selected as the best answer
William TranWilliam Tran
Naomi,  just build a new app in Lightning App Builder and hopefully your issue is resolved.

Naomi HarmonNaomi Harmon
Unfortunately, as I mentioned, I get the same error when I try to build a new app.
Katherine BootheKatherine Boothe
The DNS issue I encountered when enabling Salesforce1 Lightning Components was resolved on my instance and I'm good to go now!
Ken PeabodyKen Peabody
I'm having the same problem as Naomi.  When I try to install the ContactsToday, it installs in my production instance, not the developer instance.  I've built the My Data lightning component, but I keep getting the error that the compoonent doesn't exist.
Sunil Nandipati DForceSunil Nandipati DForce
Did you guys get this error?  How did you handle it

Your request to install package "ContactsToday Component NV2" was unsuccessful. None of the data or setup information in your salesforce.comorganization was affected.

If your install continues to fail, contact Salesforce CRM Support through your normal channels and provide the following information.

Package: ContactsToday Component (04tj0000001mMYj)
Error Number: 139397916-51539 (-291793471)

1.  Illegal assignment from List<Contact> to List<Contact>
ContactsTodayController: Illegal assignment from List<Contact> to List<Contact>

2.  Invalid constructor syntax, name=value pairs can only be used for SObjects
ContactsTodayController_test: Invalid constructor syntax, name=value pairs can only be used for SObjects

3.  No CONTROLLER named apex://ContactsTodayController found
: No CONTROLLER named apex://ContactsTodayController found
Rebecca Vanderslice 2Rebecca Vanderslice 2
i also do not have the checkbox on the Lightning Components page.  this is in a preview org, so I don't know why it owuld be missing. any ideas?
Robert RobinsonRobert Robinson
Thank you William. Worked like a charm after enabling for Salesforce1.
nusrat khowajanusrat khowaja
i have same problem here is screen 
User-added image
I am still having the same issue, I am not seeing enable for Salesforce1 even after activating the "Lightning Component usage requires My Domain" Update.

Anyone having similar issue?
Ajay Ghuge 6Ajay Ghuge 6
Hi All ,

I faced the same issues mentioned above. I tried all the solutions mentioned but when I carefully looked into trailhead it says that we need to activate the domain.

Just create domain by following the steps given in the trailhead.

After the domain deployed to the users you can see the component in the Lightning App Builder.Add it to the 'MyData' app.

Cheers !!!

saran kumar 9saran kumar 9
domine ? how
Jose Manuel MisaJose Manuel Misa
I´m following the steps and it´s impossible that 'ContactsToday' appears in custom component on 'MyData' Lightning App. Anyone has the solution?? Thanks in advance!
Ramesh DondetiRamesh Dondeti
Hi Jose,

First You Create Your domain in your org by following the given
type Domain in Quick find search Box there you will get mydomain by enabling y domain you will get your own domain then you should deploy ur users to ur domain then automatically the lightning components will appear to you in your lightning app builder
Ryan McNeelyRyan McNeely
Hi All, 

I think I've done everything mentioned here. Screenshots show:
1) Custom(0) in AppBuilder, though I expect at least a couple
2) I'm signed into my special domain
3) I have installed 2 custom components
4) Checkbox is checked for "Enable App Builder for Lightning Experience (PILOT)"

I've put a couple hours into this apparently 20 minute exercise. I'd really appreciate your help.

User-added image
User-added image
User-added image
User-added image
Dirk S.Dirk S.
Hi Ryan, you have to complete the last step in "My Domain" : deploy to users, then you should see the component in the app builder.
hehehe .... I've read this entire post and now I get this fun error when trying to create/edit any lightning pages.

An error has occurred in the following section: [Exception, DomainNotPropagated]. has been notified of this error.
An error has occurred in the following section: [Exception, DomainNotPropagated_desc]. has been notified of this error. 
Had to uninstall and reinstall package, then recreate page and everything worked.
Charu SehgalCharu Sehgal
hey did you resolved this domain name error?
Coralie B.Coralie B.
Hi all,
Could someone help me? I have created the new domain to have my lightning component ContactsToday available, but now that I want to edit my app via Lightning App Builder, I am no longer able to login ...
I click Edit on my App "MyData"
I am redirected to
I login, I see a redirection to my custom domain
I'm back at

If I look at the login history : "Success".

Hey All, 

following the discussion here it seems that the challenge is not very clear at all - anyway. To solve the trail you need to follow these steps: 

1. Install the Packages (Note: It will be automatically installed with your current login -not on the "hands-on org")
2.  Open Lightning App Builder

==== Register Your Domain ====
3. Custom Shows: "Register your Domain"
4. Follow the Link and register a custom domain. (Note: "Check availability" seems to be buggy. Use a random number + character to make it working)
5. Confirm Domain while opening the E-Mail. 
6. Login To you Domain for double-check. 
7. Deploy Domain to Users.
8. Open Lightning App Builder again
=== End Register Your Domain ===
9. The Custom Component should be now available. 

Hope this will help out. 
Hello Folks

Wondering if you guys can help me. I've already tried your answers to resolve this issue. Even after throwing my head in the different direction for last 2 hours, I'm still stuck on the same problem. I manage to install the Opportunity Alert Component, but 'ContactsToday' custom component is not getting installed. It is throwing the below error –
User-added image
I've already taken few measures to verify this problem like Enabling Lightning Components, but not solution.
User-added image
Did anyone has come across such issue, Would glad to know the steps you have undertaken.

I want to earn the badge, just hanging at the tail end.

Any help - much appreciated.

Troy StoneTroy Stone
Hi Manoj, have you had any success?  I installed several components from appexchange and I simply want to use them in the app builder.

This seems to be a widely discussed topic, and I am sort of embarrassed that I can't figure it out.   I've been able to replicate various portions of our web site in VF/APEX porting from PHP w/API.  I wanted to attempt to recreate other portions using the lightning environment.  In our org we have a long list of components, including several I downloaded. In the app builder, only the standards show.  Clicking My Domain shows a domain name, with step 4 highlighted.  I'm working in our developer sandbox which is a snapshot of prod.

This part of the dev guide seems to indicate 3 steps - setting up a domain - which seems already done, Add a New Interface to Your Component, and Add a Design Resource to Your Component Bundle.  

It seems as if step 2 and 3 indicate creating code fragments that expose the component to the app builder somehow.  I'm having trouble understanding what needs to done to get the components to show up in the builder.  

If someone can give me even the slightest insight of what I am missing in concept here I'd greatly appreciate it.
Lisa SouletLisa Soulet
@christopher.ramm has the correct solution.  I was running into most of the issues above, but as soon as I registered and deployed my domain, the "ContactsToday" custom component showed up in my Lightning Components pane.  Thank you, Christopher.  Now I can earn by badge!
Oovais Mansuri 1Oovais Mansuri 1
Hi All,

After deploying my domain, I am not able to access the Lightning App Builder. It redirects me to the salesforce login page everytime. Please help me resolve this issue.

Thanks in advance
David Richards 3David Richards 3
HI all,
Taking the final Challenge of Lightning App Builder and stuck at first base.  
Unable to install the custom component; have tried incognito etc and still get the:
"This app can't be installed. There are problems that prevent this package from being installed. Insufficient PrivilegesYou do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary."

Anyone able to define a simple solution?
Johana BradleyJohana Bradley
After creating My Domain and deploying to Users, I was able to see the Opportunity Alert on Lightning Components.
Deanna Foukal 15Deanna Foukal 15
Hey guys, I'm trying to install the package and getting an error everytime.  Any ideas?Error when trying to install unmanaged package for Trailhead Challenge
Alison ArmstrongAlison Armstrong
I'm having a similar problem as Deanna, different error message. I rebooted. I used the incognito window and nothing changed. Please advise what I need to do to get sufficient privileges. Thanks!
User-added image
Penelope ThompsonPenelope Thompson
 After I just pasted the last part of the URL into my web browser the install worked.  It kepted trying to log me into my work instance of salesforce and install rather than the trailhead org.  And that is what caused me to get the errors in install.  I already had the domain deployed. User-added image
Akila GaneshAkila Ganesh
Hi folks

As suggested by you all I tried doing every possible step and still the custom component "ContactsToday" was invisible in launched Trailhead Playground while it was visible in Sales or Marketing grounds when I tried following the same steps. However challenge is incomplete unless you download the custom component into trailhead playground. So in order to make the custom component visible in trailhead playground, I tried these steps:
1. Open the link "Install this unmanaged package" as mentioned in the challenge requirements
User-added image2. The link will open in new tab where it showed the package is already installed and hence uninstall before installing a new versionUser-added image3. Click done and it will take you to the installed packages page where you can see Contacts Today. Also you will see that the page is changed to Sales App rather than Trailhead Playground where the custom component is installed. Also you cant see the trailhead palyground option in the dropdown which means that this custom component is not available for use in your trailhead account or developer org.
User-added image4. Click the Contacts Today and then view components. In the view components page, click the ContactsToday link under Package components section.
User-added image5. You can see the link to developer console which will take you to the developer console. Once you are in developer console you can see the code for the following items:
"ContactsToday" component
"ContactsToday" controller
"ContactsToday" helper
 "ContactsToday" Style
 "ContactsToday" ​Documentation
"ContactsToday" renderer
"ContactsToday" design and
"ContactsToday" SVG
Make sure you copy the codes for all these sections in a notepad and keep.

User-added image
 6. Now launch the trailhead playground from your challenge and then open the developer console under your profile. In the developer console, perform the following actions

1. Click New "Lightning Component" <- Name it "ContactsToday" <- Check Lightning Page under "Create bundle with any of the following configurations (optional)" and Click Submit

2. Copy paste the code which we had copied in the notepad before for component, controller, helper, Style, Documentation,  renderer, design and SVG and then click save

3. Then navigate to Test tab and click run all and make sure there are no errors while copying code. Once it shows success, go to "Lightning App Builder" page from quick find and open "MyData" Lightning page and refresh.
You can see the ContactsToday Custom Component visible now.

Note: Before starting to follow the below steps make sure your domain is properly installed in My Domain page (The instructions of which are given clearly in the challenge)

This is how I finished my task.

Thanks & Cheers.
Have a good day!
Vaishnavi Sharma 14Vaishnavi Sharma 14
I have created my domain in existing org.
still, my lightning component(beta) is not available.
Do I need to create fresh org to use lightning components?
Naveen KNNaveen KN
In case if nothing works out, try this solution  (" target="_blank)
Nisha GodeNisha Gode
Thank you Akila! Once I built it myself, I was able to insert it and get my badge.
Aditya DeshmukhAditya Deshmukh
Thank you Akila ! What you suggested really helped.
Tong He 5Tong He 5
Expereinced similiar issue not seeing the custom lightning components in the app builder. It turned out for me that I needed to create a custom domain, wait for the salesforce email to arrive, login to that domain and deploy the domain to users. After I was done with that, the custom component magicially shows up.
Venkatesh SatyamoorthyVenkatesh Satyamoorthy
I am also facing this issue with component that was created as part of the Learning of Javascript for lightning from Pluralsight is not available to select in student object lightning record type pages. I have done the following prerequiside.

Create my domain
Applied the my domain to all users.
Create a student object
Created a lightning componnet with a button and a field that show the status of the Apply for Aid for a student as described in Pluralsight learning site.
Create a Lightning record page and added the record detail for the student object.
Now i am trying to add the lightning component that has a button to the lightning record page and see that it is not available for addition. 

Any help is much appreciated to help me move further with my learning.
Brenda HarwellBrenda Harwell
Hello -
I struggled with not being able to locate the Opp Alert app. once it installed. The problem:  the app. said it installed successfully, but I couldnt find it.  I noticed after I pasted the url from the trailhead module & hit the enter key, the browser changed and installed the Opp Alert in another org. than my Trailhead playground.  I carefully edited the first part of the url to match my trailhead playground url, where I wanted the apps. installed.  
James Pineda 7James Pineda 7
Hi Brenda,
Thanks for your post. I'm a little confused, though.  When you stated that you "...carefully edited the first part of the URL...", what did you mean?  I've tried variations of combining the URL of my Dev org with the given URL for the opp alert install package...and I'm not getting anywhere.  Could you provide an example?
Brenda HarwellBrenda Harwell


Sure!  In my case I have multiple dev accounts, including the Trailhead Playground.  For example if your dev account url is similar to:
and your trailhead playground url is similar to:  https://skippy-mouse

You want to edit the url text shown in bold above to be your Trailhead Playground account, before you hit the enter key fto run the Opp Alert/components install.  

Hope that helps!

James Pineda 7James Pineda 7
Hi Brenda,

Thanks for your speedy response!  It definitely helped.  I have the same multiple dev accounts/Trailhead Playgrounds the first time I installed the opp alert package, the install defaulted to my original, named/login dev org.  Since I performed the install with only the target Playground ("rickety-rat-123456") running, I assumed that it would install there.  As you know, this is definitely not the case.

Here's what worked for me:
I used copy and paste features to speed things up and reduce keystroke errors.  I would have solved this problem yesterday on my own if I had done this. Keystroke errors. Doh!!! Thank goodness @BrendaHarwell got me back on track!!!

This is the install package location:

Here's the URL for the setup home page of my target dev org:

Your install package URL should look like this:

Another example, using my dev org alias:

There's no need for resetting passwords or anything else.

Thank you @BrendaHarwell!
James Pineda 7James Pineda 7
Trailhead Challenge:

Same situation:

I hope this helps.

Good luck!
chandra v 14chandra v 14
Hi, Refer to this,
Jarrell DunsonJarrell Dunson
Hey everyone, this worked for me: 

Replace the "" with your Playground URL... so the compenents are added to your playground URL...

[Playground URL]/packaging/installPackage.apexp?p0=04tj0000001mMYP 
[Playground URL]/packaging/installPackage.apexp?p0=04t1a000000REQ2

Shobha SrikantaswamyShobha Srikantaswamy
Creating the domain, registering it and activating the domain for the user will resolve this issue.
Gwenn Ferguson 4Gwenn Ferguson 4
Thank you Jarrell, you gave me the answer. I wasn't saving it to my specific playground that I was using for the Trailhead. Once I changed the URL to include my playground information it worked!
Liliana Centra 3Liliana Centra 3
I solve same problem with <isExposed>true</isExposed> attribute in xml metadati in to the component.

Divya Goel 3Divya Goel 3
Hello Everyone,

I tried editing my trailhead playground and changed it to have the packaging location as:
[Playground URL]/packaging/installPackage.apexp?p0=04tj0000001mMYP 

But still it shows the same error on installing the unmanaged package.

This app can't be installed.
There are problems that prevent this package from being installed.
Package Not FoundThe requested package doesn't yet exist or has been deleted. If this is a recently created package version, please try again in a few minutes or contact the package publisher.

Please let me know of any other work around.??


Abhishek Gowda KAbhishek Gowda K
how to correct this any idea...please
Abhishek Gowda KAbhishek Gowda K
help me to correct this error
Fomezeu Nanjoue BrinaileFomezeu Nanjoue Brinaile
hey Divya. i have also copy the second link of JARRELL and paste can try it in inconido Browser

thank Jarrell Dunson
Palak DadheechPalak Dadheech
Hello Everyone,
I am trying to solve Install an AppExchange Solution challenge. I am getting this error-
"Challenge not yet complete in My Trailhead Playground 1
We couldn't find theFlow Video Player & File Viewer Flow Solution in your org. Make sure you installed the package in the correct org and try again".
Can you please, suggest some solution. Have already spent one day on this, still stuck :( 
Marcin MyśliwiecMarcin Myśliwiec
Hi guys,

I had the same issue so I thought to try create this component manually it worked.

All you have to do is to:
1. Go to your Developer Console
2. Click file -> new -> lighting component
3. Create component with a name "ContactsToday" and additionally just check all checkboxes (just to be sure)
4. I've added some dumb html like:
<h1>Hello from Contacts Today</h1>
5. Done!
Parul Vinchurkar 9Parul Vinchurkar 9

Directly launch your playground and goto Install Packages and Install 04t1a000000REQ2 for Contacts Today.
This worked for me.

Aman Kumar Mishra 13Aman Kumar Mishra 13
I had this exact problem .
Just go to custom components -->deploy the domain--->log in to the domain---->refresh the lightning app builder page --> custom components would be there