function readOnly(count){ }
Starting November 20, the site will be set to read-only. On December 4, 2023,
forum discussions will move to the Trailblazer Community.
+ Start a Discussion
Jennifer W. LeeJennifer W. Lee 

Need help on Mobile SDK module - getting started with hybrid development

I followed all the instructions on the Getting Started with Hybrid Development module (

When I put in the command - "cordova emulate android", when it tried to run the app, I got an error "net::ERR_FILE_NOT_FOUND (file:///android_asset/www/index.html)

Any thoughts?
ShashankShashank (Salesforce Developers) 
Please see if these links help:
Richard Clarke - Artisan ConsultingRichard Clarke - Artisan Consulting
I am getting the same problem.  Which I "fixed" by moving the CSS/JS and HTML files into my app from a prior hybrid local app which worked.  The app then loads but it shows the index.html page when it should be working as a hybrid remote app and accessing a page.
Richard Clarke - Artisan ConsultingRichard Clarke - Artisan Consulting
To add more detail to this - after generating a cordova hybrid_remote project the generated config.xml file contains
<content src="index.html" />
That reference to index.html is what is causing the file not found error - change it to something else and the error changes
Changing this to reference for example will display salesforce in the app and the user can log in
But it is not doing the OAUTH process and it is not accessing the VisualForce start page
It feels like the generated contact tag is wrong and should reference the entry point for the OAUTH process
Any ideas anyone?
#mobilesdk #oauth
Ales DrobyshAles Drobysh

I have just got stuck th the same problem and have no idea how to solve it.


Does anybody have any solution for this?

Craig IsaksonCraig Isakson
Has there been a solution found for this yet?  I am running into the same issue when creating a hybrid remote app with forcedroid v 4.2.0.
Craig IsaksonCraig Isakson
I found an answer that worked for me from a post in the G+ community.  If anyone is having the same issue, try this:
It could be that something has gone awry. Something you could try is to remove and re-add the plugin with the following;
$ cordova plugin remove com.salesforce
$ cordova plugin add
Doing this will re-run the post-install scripts and might throw an error.