+ Start a Discussion
rohit patilrohit patil 

Index.html not found error in SalesforceHybridRemoteApp

I followed the steps necessary for creating a hybrid remote app. But once I build and run the project I am getting error index.html is missing. 

1) forcedroid create 

2) fill in all the remaining things 

3) change bootconfig.json file with connected app value etc . 

4) Cordova prepare 

In bootconfig.json, I replaced remoteAccessConsumerKey with the right value from my developer org. The start page is "/apex/myStartPage", which is just a simple page printing some static text. But when I ran this app in Eclipse, android simulator comes up but with no salesforce login page. Instead it is giving error as "Index.html not found".Can you point out where I possibly missed in the setup? 
Steve Wallace 9Steve Wallace 9
I had this problem - things got better when I made sure that the app I created was hybrid_remote, that the starting page was set as /apex/HybridPage - and finally, and perhaps most significantly, that I had the GIT utility installed and available from the command line. Then when I did 'forcedroid create' - it downloaded and updated a load of stuff and - it worked. That said Trailforce won't admit that it has - I really want those 500 points!
Steven GrecoSteven Greco
I still have the same issue. I created a hybrid remote app, set the bootconfig.json, and used the Git utilitly. Rohit, did you have any luck with this?
Ajay Singh SolankiAjay Singh Solanki
Did anybody got any luck on this? I am too facing the same issue after following all the steps mentioned for creating mobile hybrid remote app.
Leanbridge TechnologiesLeanbridge Technologies
First of all, I saw that I referenced to an older version (1.4) of PhoneGap. I downloaded the newer version of the javascript component and replaced it, but it didn't help.