+ Start a Discussion

"No Apex class named 'NewCaseListController' was found"

Trying to finish the "Visualforce Basics" trail and I think I'm encountering a system error rather than a "me" error.

When I check the challenge I get this error: "No Apex class named 'NewCaseListController' was found" (http://screencast.com/t/AeGb37gjnod)

But I definitely created the class, it's definitely named 'NewCaseListController', and the page I wrote is definitely working correctly:
http://screencast.com/t/XJ1CjjYebwv and http://screencast.com/t/10aDrf5Vu

Can anyone else's eyeballs spot something I've done wrong here? I also tried logging out of everything completely and reconnecting, but still no luck...
Amit Chaudhary 8Amit Chaudhary 8
Please try to create the class with same name again

If it will give you error while saving them try to submit challange again.


Please share screenshot of VF page also.

@Amit -- no luck with that. I can't save a new page with that name, but the challenge still can't find it!

@Vishal -- here's the VF page: http://screencast.com/t/mBaNo3DmVy
Hi Michelle,

Is it possible for you to share your org with me, so I can check and resolve your issue. My email id is vishal.er.gupta@gmail.com

Amit Chaudhary 8Amit Chaudhary 8
Your code should be like below
<apex:page controller="NewCaseListController">
    <apex:form >
        <apex:pageBlock title="Case List" id="Case_list">
            <!-- Case_list -->
         <apex:repeat value="{!Case}" var="cs">
            <apex:outputLink value="{!cs.Id}">{!cs.Id}</apex:outputLink>
            <apex:outputLink value="{!cs.CaseNumber}">{!cs.CaseNumber}</apex:outputLink>
Public class NewCaseListController {
List<Case> results = new List<Case>();

private String sortOrder = 'CaseNumber';
public List<Case> getCase() {
    results = [SELECT Id, CaseNumber FROM Case WHERE Status = 'New'];

    return results;
Its realy strange why it saying class is now found. Even you code is also fine :( . I hope you are connecting with right org while submitting the challange ?

Anyone figure this out? I'm getting the same error. It's frustrating because I'm one section away from getting this badge! >_<
@josh -- you know, I just went back to try and figure out what was happening here... and I have no idea. One thing to try: if you've been working in your dev org for a while on various projects, try spinning up a fresh one and doing the work in there and connecting to that new one for this challenge. I think someone suggested that to me at some point (though I can't remember if it was the solution to THIS problem, or something else I was experiencing...)
Thanks, I've figured it out already. I just deleted everything and restarted from scratch.